Crash in netscp6.exe when sending mail - local sent folder problem

VERIFIED FIXED in M17

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: John Unruh, Assigned: rhp (gone))

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
I'm using IMAP, and sending any mail, even without ssl turned on, crashes 
netscp6.exe. Build 70708.

Comment 1

18 years ago
That's good that it crashes even without ssl because we don't support smtp over
ssl =).

I'm able to send mail okay with todays bits. Lisa, did anyone in QA run into a
smoketest blocker with this today?

junruh, did your crash lead to a talkback report we can look up?
(Reporter)

Comment 2

18 years ago
At http://cyclone, fastfind junruh@netscape.com, incident 13770418. 7/7 11:30.

Comment 3

18 years ago
Here's the stack trace from that report:
Looks like we are barfing with your sent folder. Since jefft is out on
sabbatical, load balancing to rhp. rich, can you help take a look at this?

 nsLocalMailCopyState::~nsLocalMailCopyState
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsLocalMailFolder.cpp, line 371]
    nsLocalMailCopyState::`scalar deleting destructor'
nsMsgLocalMailFolder::ClearCopyState
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsLocalMailFolder.cpp, line
1792]     nsMsgLocalMailFolder::EndCopy
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsLocalMailFolder.cpp, line
2358]     nsMsgLocalMailFolder::CopyFileMessage
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsLocalMailFolder.cpp, line
1959]     nsMsgCopyService::DoNextCopy
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgCopyService.cpp, line 247]
   nsMsgCopyService::DoCopy
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgCopyService.cpp, line 178]
   nsMsgCopyService::CopyFileMessage
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgCopyService.cpp, line 420]
   nsMsgCopy::DoCopy
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCopy.cpp, line 295]
nsMsgCopy::StartCopyOperation
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCopy.cpp, line 234]
nsMsgComposeAndSend::StartMessageCopyOperation
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 4116]
nsMsgComposeAndSend::MimeDoFCC
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 4085]
nsMsgComposeAndSend::DoFcc
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 3063]
nsMsgComposeAndSend::DoDeliveryExitProcessing
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 3017]
nsMsgComposeAndSend::DeliverAsMailExit
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 3024]
MailDeliveryCallback
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 2605]
nsMsgDeliveryListener::OnStopRunningUrl
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgDeliveryListener.cpp,
line 83]     nsUrlListenerManager::BroadcastChange
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsUrlListenerManager.cpp, line
84]     nsUrlListenerManager::OnStopRunningUrl
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsUrlListenerManager.cpp, line
113]     nsMsgMailNewsUrl::SetUrlState
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgMailNewsUrl.cpp, line 109]
    nsSmtpProtocol::ProcessProtocolState
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsSmtpProtocol.cpp, line 1483]
    nsMsgProtocol::OnDataAvailable
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgProtocol.cpp, line 191]
 nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
407]     nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
106]     PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 588]     PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 547]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1045]     USER32.dll + 0x124c (0x77e7124c)
Assignee: mscott → rhp
Keywords: crash, nsbeta2
(Assignee)

Comment 4

18 years ago
I'll put it on the stack.

- rhp
(Assignee)

Comment 5

18 years ago
Hello folks,
Well, I just tested sending on accounts setup for doing copy operations on both 
IMAP and local mail folders and both seemed to work fine without crashing.

Can anyone else reproduce? If so, please reopen.

- rhp
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
hey rich, I think you might need to take a look at junruh's account setup. I 
suspect he doesn't have a sent folder selected by default or maybe we haven't 
built a summary file for his sent folder before we try to add the first message 
to it. 

Just my guess anyway.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
Target Milestone: --- → M18

Comment 7

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 8

18 years ago
(sorry, I was late in reading bugs.)

Laurel - can you see if you can reproduce this?
Summary: Crash in netscp6.exe when sending mail → Crash in netscp6.exe when sending mail - local sent folder problem

Comment 9

18 years ago
hmm.. this looks to be very close to bug 
http://bugzilla.mozilla.org/show_bug.cgi?id=40814 that selmer filed.
(Assignee)

Updated

18 years ago
Target Milestone: M18 → M17

Comment 10

18 years ago
junruh, are you still seeing this on todays builds?

Also, is your sent folder an IMAP folder or is it a local folder?

I'd like to move this bug off the nsbeta2+ list if we can't reproduce it. Maybe
we could convince someone from QA to checkout his set up on the 2nd floor. 
(Reporter)

Comment 11

18 years ago
Marking fixed. Can no longer reproduce.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
thank you.  Mark verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.