Junk no longer moves message to junk folder after upgrade to 2.0.0.16

RESOLVED WORKSFORME

Status

MailNews Core
Filters
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Mike Browne, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-07-21)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 2.0.0.16

Build 2.0.0.16 was installed on 24/07/2008 and since then mail that arrives as junk no longer automatically moves to junk folder, even though it is marked as junk. Also if I mark a message as junk it does not move to junk folder, and clicking Tools/'Delete mail marked as junk' in this folder has no effect.

Worse, if I then move to the next message it will not display. The only way to get this to happen is to click on another folder in Local Folders, then back again to Inbox. This will then allow me to 'Delete Mail marked as junk in this folder', which in turn returns the Inbox to normal operation.


Reproducible: Always

Steps to Reproduce:
1.Click on message already marked as junk by junk filter, or mark a message as junk
2.Message does not move to Junk folder
3.Tools/Delete message marked as junk in this folder does not delete junk messages
4.Next message in Inbox cannot now be read until Junk is removed
5.Click on another file in Local Folders, then back to Inbox
6. Junk can now be deleted from Tools menu
7. Inbox now works until next Junk message arrives or is marked.

Comment 1

10 years ago
Is the prefs set correctly under Options | Privacy | Junk? 
If yes, see it without extensions? Anything interesting in the Error Console? 
Keywords: regression
Whiteboard: [->2.0.0.16 upgrade]
Version: unspecified → 2.0

Comment 2

9 years ago
Mike, do you still see the problem?  Your response will be helpful to move the bug forward.

xref Bug 440813
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Summary: Junk no longer behaves as it did → Junk no longer moves message to junk folder after upgrade to 2.0.0.16
Whiteboard: [->2.0.0.16 upgrade] → closeme 2009-07-21
Version: 2.0 → unspecified
(Reporter)

Comment 3

9 years ago
Hi Wayne,

No - the bug disappeared, I can't remember when! Probably as a result of another upgrade.

We have just upgraded to the latest version (2.0.0.22) and now we can no longer email invoices etc from our accounts program as it says there is no email set up on our machines. All that have been upgraded have the same problem.

I went on the Mozilla site and found reference to this general problem, to do with MAPI. I followed the instructions to check the register entries and amended them but it has not resolved the problem.

Hopefully this will also correct itself in future upgrades.

Regards
Mike Browne

Comment 4

9 years ago
->WFM then. Thanks for checking!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.