Closed Bug 448023 Opened 12 years ago Closed 3 years ago

Can't use keyboard commands when focus is on java applet

Categories

(Firefox :: Keyboard Navigation, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: marcia, Unassigned)

References

()

Details

Seen while testing Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a1) Gecko/2008072510 Shiretoko/3.1a1.

STR:
1. Visit site. Java applets will be missing, but that is expected.
2. Put focus on the Java applet (center of the page).
3. Ctrl+T or any other keyboard command.

Expected: A new tab would open or the keyboard command would be initiated
Actual: The menu flashes.

As soon as you remove focus from that area keyboard commands work fine. 

The same thing happens in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1 when I place focus on the java applet shown.
I believe this is already on file so I will try to find the dupe.
Whiteboard: DUPEME
I was thinking of bug 428047, but that's supposed to be fixed now.
> I was thinking of bug 428047, but that's supposed to be fixed now.

It turns out this bug _didn't_ get fixed for Java applets (though it
did for other plugins, like Flash and Quicktime).

I just tested with the 2008-04-29-04-trunk Minefield build (the first
one containing the patch for bug 428047).  Somehow we missed this in
our testing at bug 428047 (which, to be fair, was plagued with all
kinds of other problems).

Unless we find that other plugins are also effected, let's not re-open
bug 428047.  If it's just a Java problem (or a JEP problem), this bug
covers it nicely.
Whiteboard: DUPEME
As far as I can see, Flash & QuickTime movies, and Shockwave games, don't cause any problem anymore (Minefield/mozilla-central & Camino 2.0a1pre)
isn't this a dupe of bug 78414 ?
(In reply to comment #5)
> isn't this a dupe of bug 78414 ?
 
The same reasoning applies here as for bug 428047, I think. It used to work on Mac (Fx 2). See bug 428047 comment 8 ~ 10.

The HTML <applet> element and related java functionality was removed from Gecko in Bug 1279218. Marking related bugs as invalid.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.