Closed Bug 448064 Opened 12 years ago Closed 4 years ago

Hang moving nodes in and out display: none node and input

Categories

(Core :: Disability Access APIs, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: martijn.martijn, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: hang, regression, testcase)

Attachments

(2 files)

Attached file testcase
See testcase, which hangs current trunk build after 200ms.
You need to download the testcase to your computer because of the use of enhanced privileges.

This regressed between 2008-01-11 and 2008-01-14, it seems.
There were 2 bugfixes in that period having to do directly with accessibility:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-01-11+00:00&maxdate=2008-01-14+05:00&cvsroot=/cvsroot

bug 411737 or bug 408997 seem to be affecting this.

Martijn, when it hangs, can you segfault it manually so we get a stack trace?
I don't know how to segfault it in VC Express. How do you do that?
marcoz: please don't use 'segfault'
martijn: he just wants a stack trace, attach to it w/ vc and get a stack trace.

SEGFAULT is one of a number of ways that an application an crash, and on unix you can use kill -SIGSEGV to cause such a crash which if you have a signal handler such as breakpad will be then reported as a crash w/ the standard stack trace.

on windows this is pointless since you can just use any debugger w/ the symbol server to download symbols and get a stack trace straight from the debugger.
Keywords: stackwanted
Attached file stacktrace
Ok, I now know how to get a stacktrace from a hang. But I can't step into the code, because then my build crashes.
I have three stacks from three hangs, because every time, the stack looks differently. I also posted some debug output prior to the hang.
Yes, still hanging, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090219 Minefield/3.2a1pre
Keywords: stackwanted
Doesn't hang for me when opened locally. Can you reproduce still?
Flags: needinfo?(martijn.martijn)
Thanks for checking, it must have been fixed by now.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(martijn.martijn)
Resolution: --- → WORKSFORME
I'm going to push the attached testcase as a crashtest, but it'll be skipped by default as it appears to be also affected by bug 918246 based on the Try results.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.