Thunderbird Updater/Installer fails resulting in an infinite loop

RESOLVED DUPLICATE of bug 452162

Status

Thunderbird
Installer
RESOLVED DUPLICATE of bug 452162
10 years ago
10 years ago

People

(Reporter: raccettura, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
There are actually a few things going on here that are wrong.

Thunderbird found an update and tried to update.  The update failed because it couldn't update a file (vague error).  It then restarted the update process and failed again.  This is a seemingly endless loop of failure.

I killed the process and decided to download the Thunderbird installer and just reinstall.  Thunderbird installer failed because it couldn't write to xpcom_core.dll.  Thunderbird isn't running.

When using unlocker to see what was holding that file, to my surprise it was Firefox 3.

This bug is for the updater's endless looping.  It should give the ability to abort if it fails more than once.  I had to ctrl alt delete to kill the updater.exe process.

Not sure if this makes more sense to file under Firefox since the installer/updater code is shared, but I'll leave it here for the moment.
(Reporter)

Updated

10 years ago
Summary: Thunderbird Updater/Installer fails when Firefox 3 is running → Thunderbird Updater/Installer fails resulting in an infinite loop
(Reporter)

Comment 1

10 years ago
The Firefox part of this bug is bug 448154.
The installer and updater most likely won't be able to do anything for any app using another app's dll's beyond file in use install support which is bug 404609 for the installer and bug 340535 for software update.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340535
You need to log in before you can comment on or make changes to this bug.