Go To Today doesn't show the correct week that contains today

VERIFIED FIXED in 0.9

Status

Calendar
Calendar Views
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: ssitter, Assigned: dbo)

Tracking

({regression})

unspecified
regression
Dependency tree / graph
Bug Flags:
blocking-calendar0.9 +

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.17pre) Gecko/2008072620 Calendar/0.9pre

Steps to Reproduce:
1. Start Sunbird with clean profile.
2. Go Tools -> Options and set the first day of the week to Monday
3. Switch to Week or MultiWeek View
4. Press the Go To Today button

Actual Results:
The current day (Sunday 27-Jul-2008) is not visible in that views.
Week view shows date range Monday 28-Jul-2008 to Sunday 03-Aug-2008.
MultiWeek view shows date range Monday 28-Jul-2008 to Sunday 24-Aug-2008.
The current day is not visible in that views.

Expected Results:
Today is Sunday 27-Jul-2008.
Week view shows date range Monday 21-Jul-2008 to Sunday 27-Jul-2008.
MultiWeek view shows date range Monday 21-Jul-2008 to Sunday 17-Aug-2008.

Regression range: Works in Sunbird 0.9pre (2008072320)
                  Fails in Sunbird 0.9pre (2008072420)
Flags: blocking-calendar0.9?

Comment 1

10 years ago
Same thing with Lightning 0.9pre (2008072618)

Comment 2

10 years ago
Seems to be related to bug 447996

When I debugged into it I found out that the attribute "startOfWeek" for the day
"28. July" returns the calIDateTime object for  the 29th July. 
See calWeekInfoService.js, line 129, function "getStartOfWeek()".
called from "gotoToday" in calendar-decorated-week-view-view.xml.

Could you check this?
Assignee: nobody → daniel.boelzle
(Assignee)

Updated

10 years ago
Flags: blocking-calendar0.9? → blocking-calendar0.9+

Updated

10 years ago
Whiteboard: [needs patch]
(Assignee)

Comment 3

10 years ago
should be fixed with changes to bug 447996
Depends on: 447996
Whiteboard: [needs patch]
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 0.9

Comment 4

10 years ago
Checked with lightning build 2008081503 and sunbird 20080814 -> VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.