after setting state to 'away', will not allow me to go back to 'back'



Other Applications
10 years ago
10 years ago


(Reporter: C S, Assigned: Robert Ginda)


Windows XP

Firefox Tracking Flags

(Not tracked)




10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2008070208 Firefox/3.0.1
Build Identifier: ChatZilla 0.9.83 [Firefox 3.0.1/2008070208]

After I went to the 'away' state, I wasn't able to go back to the 'back' state. I have tried clicking on the nickname button in the bottom left, then clicking 'back', and I have also tried to type in '/back' - neither of which have worked. After two re-installs, the problem still persists.

Reproducible: Didn't try

Steps to Reproduce:
Am not able to reproduce, due to the nature of the problem.
Actual Results:  

Expected Results:  

Comment 1

10 years ago
Oh yes, also, it will allow me to change within different states of away (different away messages and such), but won't allow me to go to 'Back'.

Comment 2

10 years ago
totally will not work, because those variables aren't set. But I don't think that explains the behaviour here at all... Reporter, do you try to remove the "away" state when you're connected, or when you're not? And on what tab is this - client, or network, or something else?

Comment 3

10 years ago
That code "not working" when not online is fine, since we set preferredNick during 001 (which is when we become NET_ONLINE) based on the "away" and "awayNick" prefs, but it probably should go inside the same if inside NET_ONLINE a few lines up.

Comment 4

10 years ago
Yes, the problem persists whether I'm connected to a server or not. I don't understand what you mean about "what tab" it is on, because its not on a tab, it's integrated into the client itself. Here's a screenshot of it:

Comment 5

10 years ago
It matters (for us debugging) which ChatZilla tab you're on when you use that menu. Also, you should know that the userlist does NOT update instantly when you go away or back - but you should get a message in the chat area indicating the change within a couple of seconds when connected to a server.

Comment 6

10 years ago
do /pref away
and tell us if "away" has a value other than ""
doing /back
in the client tab fixes it if that is the case.
If you've hidden the client tab, it can be shown with the command /client

Comment 7

10 years ago
I opened the client tab and typed in /pref away and it showed this:

I then tried to use the /back command, but when I hit enter, the command sent, but nothing happened and nothing new was displayed in the client tab.


10 years ago
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.