UI: Thread Pane-Alignment of Subject column

VERIFIED FIXED in mozilla1.3beta

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: jglick, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
mozilla1.3beta
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [UE2])

Attachments

(1 attachment)

4.45 KB, patch
janv
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

18 years ago
The Mail icon associated with the "Subject" column should be shifted to the left 
so it is aligned under the column header. (It currently is shifted to the right 
to allow for the threading icons).
(Reporter)

Comment 1

18 years ago
Nominate as nsbeta3 and Priority 1 based on UE review meeting
Keywords: nsbeta3
Priority: P3 → P1
Target Milestone: --- → M18

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 2

18 years ago
reassigning to dimator.
Assignee: putterman → dimator

Updated

18 years ago
Keywords: mail2

Comment 3

18 years ago
+ per mail triage
Whiteboard: [nsbeta3+]
(Reporter)

Updated

18 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+][UE2]

Comment 4

18 years ago
P3 per mail triage
Keywords: UE2
Priority: P1 → P3

Comment 5

18 years ago
second pass: - per mail triage
Whiteboard: [nsbeta3+][UE2] → [nsbeta3-][cut 8/28][UE2]

Comment 6

18 years ago
bug owner's email is no longer valid. reassigning to default owner of component
Assignee: dimator → putterman
QA Contact: nbaca → esther

Comment 7

18 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2
(Reporter)

Comment 8

18 years ago
Adding mail3 keyword so bug is considered for 6.5.  This is Mail's most visible 
window.
Keywords: mail3

Comment 9

18 years ago
reassigning to sspitzer
Assignee: putterman → sspitzer

Comment 10

18 years ago
changing qa to nbaca,  3-pane issue
QA Contact: esther → nbaca

Comment 11

18 years ago
marking nsbeta1-
Keywords: nsbeta3 → nsbeta1-
Whiteboard: [nsbeta3-][cut 8/28][UE2] → [UE2]
clearing milestone, m17 and m18 are meaningless now.  these need to be triages
along with the rest.
Target Milestone: M18 → ---

Comment 13

18 years ago
*** Bug 65939 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
I suggest assigning a keyword or milestone of mozilla0.9

This sounds like an easy fix - low cost, high reward (keyword: mail6)

Comment 15

18 years ago
Jglick: where should we put the threading icons if we left-align the text?

Comment 16

18 years ago
could it be made dynamic?

When "threaded" view is selected, the message subjects (and small envelope
icons) shift a bit to the left to make room for the small triangle (to open
collapse thread); and when "non-threaded" view is selected the subject and icons
shift right a bit.

This seems to be the best possible solution, although it is also the technically
most difficult to implement.

Comment 17

18 years ago
The nsbeta1- means it's not going to be worked on by a Netscape engineer in the
Mozilla0.8 or 0.9 milestones.  It's currently owned by a Netscape engineer, so
it's not going to be worked on.

If someone wants to take this it would be great. I don't think it would be that
hard.  You would just have to remove and add the indentation depending on
whether or not the view is threaded.

Comment 18

18 years ago
We do other context sensitive manipulation of the thread pane as well.  Take a
look at how the Sent folder is handled in regard to switching the
Sender/Recipient column.
(Reporter)

Comment 19

18 years ago
Suggestions from Peter Lairo, on 2001-01-23 06:20, is what I was thinking.

Comment 20

18 years ago
that would be the only way to do it. It shouldn't be hard to implement.

Comment 21

18 years ago
Bug 40014 looks like a dupe of this to me? Thoughts?

Comment 22

18 years ago
actually bug 37336 seems more of a dupe.

Comment 23

18 years ago
Seth, will this be fixed in the new performance branch?
OS: Windows 98 → All
Summary: UI:Thread Pane-Alignment of Subject column → UI: Thread Pane-Alignment of Subject column

Comment 24

18 years ago
Bug# 37336 is not a dupe because it talks about the horizontal alignment (i.e.
the Subject text might appear lower than the Sender text)
(Reporter)

Updated

17 years ago
Keywords: UE2

Comment 25

17 years ago
Wow, almost filed a dupe.  The subject alignment does look a little weird when
you're not threaded.

Comment 26

17 years ago
It's more than an aesthetic issue. When viewed on 15" screen, available space
for headers is reduced below acceptable levels, because of this bug and bug 79224.
(Reporter)

Updated

17 years ago
Keywords: mail3 → nsbeta1

Comment 27

17 years ago
Hi, is the backend available for this?  I've been poking around the xul and css
files due to bugweek, and it seems like it's fixable using patchmaker.  I'd like
to work on this.
the twisty shows up in the subject column because it's the primary column.

see threadPane.xul (primary="true")

If this makes sense to you:  when in flat (non threaded) mode, all of our
"threads" are empty, so no thread twisties shows up.
something to try, not sure if it will work:

var subjectCol = getElementById("subjectCol");
if (threaded mode)
  subjectCol.setAttribute("primary","true");
else 
  subjectCol.removeAttribute("primary");

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 29

17 years ago
Hi Seth, I've tried using your suggestions and I need your advice.
First, for testing purposes I am placing the code to check for the Subject 
alignment in the HandleColumnClick(columnID) function in threadPane.js (I 
assume we will also need to make this check whenever a new folder is loaded 
and on startup).  So for now, this code will run whenever a column header is 
clicked on.  I have:
    var subjetCol = document.getElementById('subjectCol');
    if (dbview.sortType == byThread)  {
      subjectCol.setAttribute("primary","true");
    }
    else {
      subjectCol.removeAttribute("primary");
    }

Now, for testing purposes I tried just turning off the column indent, so I 
only used these two lines:
    var subjetCol = document.getElementById('subjectCol');
    subjectCol.removeAttribute("primary");

but this causes the script to fail and nothing happens when I click on a 
column.  The variable declaration line by itself doesn't break the script.  I 
have also tried       
subjectCol.setAttribute("primary","false");
but this doesn't work either.  

I suspect this is just be a matter of syntax, and I am not very good with js 
so my mistakes may be very obvious.  Do you know what could be wrong?

Updated

17 years ago
QA Contact: nbaca → olgam

Updated

17 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: --- → mozilla1.2

Comment 30

16 years ago
I remove nsbeta1- keyword - it was for MachV.
Keywords: nsbeta1-

Comment 31

16 years ago
Now I add 'nsbeta1' keyword for Buffy. Sorry, it's faster to edit multiple bugs
at once than manually go to each and remove minus.
Keywords: nsbeta1

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+
Target Milestone: mozilla1.2alpha → mozilla1.3beta

Comment 32

16 years ago
per gayatri changing qa contact
QA Contact: olgam → laurel
(Assignee)

Comment 33

16 years ago
Created attachment 111501 [details] [diff] [review]
Proposed patch
(Assignee)

Updated

16 years ago
Attachment #111501 - Flags: superreview?(sspitzer)
Attachment #111501 - Flags: review?(varga)

Updated

16 years ago
Attachment #111501 - Flags: review?(varga) → review+
testing / reviewing now

re-assigning to neil
Assignee: sspitzer → neil
Status: ASSIGNED → NEW
Comment on attachment 111501 [details] [diff] [review]
Proposed patch

sr=sspitzer
Attachment #111501 - Flags: superreview?(sspitzer) → superreview+
tested and reviewed, looks good.

fixed checked in.

thanks neil!
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 37

16 years ago
Woo Hoo! Thank you Neil! Nice work. :-)

Comment 38

16 years ago
Not working for me (2002011508, Win2K) but it's better to hear your experience
before reopening:
1. I had "thread" icon disabled so when I used the latest build I said "wow!".
It was fixed.
2. I activated "thread", then de-activated it.
Now the ugly spaceon the left re-appeared. Shutting down Mozilla and restarting
it doesn't cure the problem. Imo we don't have to file a new bug on this.

Comment 39

16 years ago
The problem was caused by not having any sort method selected (i.e. there was no
arrow on any column header in the thread pane). It was a glitch produced from
the steps I described above. After clicking on a header, the fix is working
again and I can't reproduce the issue. Strange.

Comment 40

16 years ago
Using trunk build 20030131 on winxp, mac osx and linux this is fixed. verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.