make |-s| + configure |--disable-installer| = does not build

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
{{
.../mozilla/browser/app/firefox.exe.manifest:manifest authoring warning 81010002:Unrecognized Element "trustInfo" in namespace "urn:schemas-microsoft-com:asm.v3".
}}


Windows 2000: Visual C++ 2005sp1 (Express Ed.) + Platform SDK 2003r2
Current mozilla-central

[
ac_add_options --disable-vista-sdk-requirements
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../../objdir-Firefox
ac_add_options --enable-application=browser

ac_add_options --disable-installer
...
]

Without the latter option, build completes and runs fine.
Do you have any reason to believe this bug has anything to do with bug 224999 besides them both being about building with --disable-installer? I ask because all of the old installer has been removed which that bug was for.

(In reply to comment #0)
> {{
> .../mozilla/browser/app/firefox.exe.manifest:manifest authoring warning
> 81010002:Unrecognized Element "trustInfo" in namespace
> "urn:schemas-microsoft-com:asm.v3".
> }}
This warning has nothing to do with the installer. Is this the only warning you got?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Do you have any reason to believe this bug has anything to do with bug 224999
> besides them both being about building with --disable-installer?

No other reason.

> This warning has nothing to do with the installer. Is this the only warning you
> got?

That's when the build quits...
I'll redo builds with/out this option and let you know.
Removing dependency on bug 224999... we have a new installer and have added manifests which this bug mentions since that bug.

I'm doing a build with --disable-installer to see what happens... I suspect that the incorrect version of midl.exe with Visual C++ 2005sp1 (Express Ed.) is the cause.
No longer depends on: 224999
(Reporter)

Comment 4

11 years ago
Oh, I still had the last window open, in silent mode:
{{
[...]

../../dist/include/string\nsUTF8Utils.h(628) : warning C4309: '=' : truncation of constant value

Creating Resource file: module.res

[...]/mozilla/browser/app/firefox.exe.manifest:manifest authoring warning 81010002:Unrecognized Element "trustInfo" in namespace "urn:schemas-microsoft-com:asm.v3".
}}

The former is always there.
The latter, only with this option, I think.
Anyway, that is how it ends.
(In reply to comment #3)
> I'm doing a build with --disable-installer to see what happens... I suspect
> that the incorrect version of midl.exe with Visual C++ 2005sp1 (Express Ed.) is
> the cause.
I meant to say mt.exe

I just successfully finished a build with --disable-installer and it worked fine using:
Platform SDK version: 5
Setting environment for using Microsoft Visual Studio 2005 x86 tools.
Mozilla build environment: MSVC version 8.
Ted, any idea what would cause this?
Serge, could you run mt.exe and rc.exe and report back the versions? Thanks
can you pastebin the whole end of your build log? I've seen that warning before, and it wasn't fatal. 
(Reporter)

Comment 9

11 years ago
(In reply to comment #7)
> Serge, could you run mt.exe and rc.exe and report back the versions? Thanks

{{
"Mozilla tools directory: [...]\mozilla-build\"
Visual C++ 8 Express directory: [...]\Microsoft Visual Studio 8\VC
Platform SDK directory: [...]\Microsoft Platform SDK for Windows Server 2003 R2
Platform SDK version: 5
Setting environment for using Microsoft Visual Studio 2005 x86 tools.
Mozilla build environment: MSVC version 8.

*** VC++

Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.42 for 80x86
Copyright (C) Microsoft Corporation.  All rights reserved.

Microsoft (R) Incremental Linker Version 8.00.50727.42
Copyright (C) Microsoft Corporation.  All rights reserved.

Microsoft (R) Windows (R) Resource Compiler Version 5.2.3690.0
Copyright (C) Microsoft Corporation.  All rights reserved.

*** SDK

Microsoft (R) 32b/64b MIDL Compiler Version 6.00.0366 
Copyright (c) Microsoft Corporation 1991-2002. All rights reserved.

Microsoft (R) Manifest Tool version 6.0.4071.0
Copyright (c) Microsoft Corporation 2004.
}}
(Reporter)

Comment 10

11 years ago
I just completed a build with only the options listed in comment 0 :-)
I must be an interaction with one one my other options.

Sorry for partial report: it started when I added this option...
I'll narrow it down: stay tuned.
(Reporter)

Comment 11

11 years ago
(Took multiple(!) builds to fully narrow it down, as it turned out to be what I "least" expected :-<)

The (culprit) missing option from comment 0 is
[
mk_add_options MOZ_MAKE_FLAGS="-s"
]

Eventually confirmed by re-adding all my other options but this one.

***

Fwiw, I noticed that the log could end with 3 additional lines
{{
.../mozilla/browser/app/firefox.exe.manifest:manifest authoring warning 81010002:Unrecognized Element "trustInfo" in namespace "urn:schemas-microsoft-com:asm.v3".

creating tools/test-harness/Makefile
creating tools/test-harness/xpcshell-simple/Makefile
creating tools/test-harness/xpcshell-simple/example/Makefile
}}

when I add the following options
[
mk_add_options MOZ_MAKE_FLAGS="-s"
]
or
[
mk_add_options MOZ_MAKE_FLAGS="-j8 -s"
ac_add_options --disable-mochitest
]

I must have deactivated this latter option when I first reported the bug.

***

Robert, Ted, back to you !
Summary: |--disable-installer| does not build → make |-s| + configure |--disable-installer| = does not build
(Reporter)

Comment 12

11 years ago
Oh well, you have my apologies ! All is working as expected.

***

I checked again, but with SeaMonkey.

With Installer:
{{
...
../../mozilla/dist/include/string\nsUTF8Utils.h(628) : warning C4309: '=' : truncation of constant value

Creating Resource file: module.res

iconv -f UTF-8 -t CP1252 instgen/nlf.in > instgen/baseLocale.nlf
iconv -f UTF-8 -t CP1252 instgen/override.properties > instgen/overrideLocale.ns
h
iconv -f UTF-8 -t CP1252 instgen/mui.properties > instgen/baseLocale.nsh
iconv -f UTF-8 -t CP1252 instgen/custom.properties > instgen/customLocale.nsh
MakeNSIS v2.22 - Copyright 1995-2006 Contributors
...
}}

Without installer:
{{
...
../../mozilla/dist/include/string\nsUTF8Utils.h(628) : warning C4309: '=' : truncation of constant value

Creating Resource file: module.res
}}

***

So, the comment 0 "warning" did confuse me when I switched applications :-((

I confirm that warning is unrelated to the installer (= always there, filed bug 448351 !).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.