Connection: hide arrows (hidespinbuttons) for port number

RESOLVED DUPLICATE of bug 1437302

Status

()

Firefox
Preferences
--
minor
RESOLVED DUPLICATE of bug 1437302
10 years ago
2 months ago

People

(Reporter: benc, Unassigned)

Tracking

({ux-minimalism})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Firefox 3 is getting "spinboxes" from textbox.type=number.

For port numbers, there isn't any practical use for spin numbers, you aren't going to modify the port number by ticking up and down w/ the arrows:

http://mxr.mozilla.org/seamonkey/source/browser/components/preferences/connection.xul#123

<textbox id="networkProxyHTTP_Port" type="number" max="65535" size="5"
preference="network.proxy.http_port" onsyncfrompreference="return gConnectionsDialog.readHTTPProxyPort();"/>

We should add: "hidespinbuttons=true" to all the port number fields.

http://developer.mozilla.org/en/docs/XUL:Attribute:hidespinbuttons

Comment 1

a year ago
Maybe it has some effect, such as minor adjustments for typing errors or new ports.
Severity: normal → minor
Keywords: ux-minimalism
Summary: Connection: remove arrows from port number. → Connection: hide arrows (hidespinbuttons) for port number

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1437302
You need to log in before you can comment on or make changes to this bug.