Text-Characters change their positions, when moving with the mouse over them

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Patrick R. Gansterer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

99.39 KB, application/x-bzip2
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008072703 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008072703 Minefield/3.1a2pre

-

Reproducible: Always

Steps to Reproduce:
1. Open the URL
2. Hold the Ctrl-Key and move the mouse over the text which is aligned to the path
3. The Characters of the text will jump around

Maybe you must play with the zoom to reproduce it...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008072703 Minefield/3.1a2pre

This works fine for me. Could you give additional steps to reproduce?
(Reporter)

Comment 2

10 years ago
Created attachment 331566 [details]
Screencast

(In reply to comment #1)
I took the first program for screencasts (CamStudio) i've found and recorded my "steps". My Ctrl-Key was pressed during the mouse-move.

I hope this helps.
When I view the inkscape example document mentioned, many glyphs are missing from the Indic text along the curved paths (compare the text on the paths to the equivalent straight-line text). Associated with this are many assertions:

###!!! ASSERTION: Cannot draw partial ligatures without a dirty rect: 'Error', file /Users/jonathan/mozdev/mozilla-central/gfx/thebes/src/gfxFont.cpp, line 1633

which probably relate to each glyph (or glyph fragment) that does not appear.

Problem seen on both Mac OS X and Windows Vista with recent trunk builds.
Fixed on trunk provided you have Vista or Windows 7 and direct write is enabled (gfx.font_rendering.directwrite.enabled = true)

The assertions in comment 3 still happen though.
Depends on: 527707
Duplicate of this bug: 603060
Works OK now. Various bugs probably contributed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.