Closed Bug 448333 Opened 13 years ago Closed 13 years ago

Graphical corruption halfway down planet.ubuntu.com

Categories

(Core Graveyard :: GFX, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 215055

People

(Reporter: dholbert, Assigned: vlad)

References

()

Details

(Keywords: regression, testcase)

Attachments

(3 files)

Steps to reproduce:
 1. Load URL (or download attached zip file and load planet/planet.html)
 2. Ctrl-F to open 'find', and type "personal surprise"
  (This takes you to the "Dolphin" section of Juan Carlos Torres' KDE review)
 3. Scroll down a bit.

ACTUAL RESULTS:
  The area just below (and sometimes, directly surrounding) that bit of text is corrupt.  It looks like a full viewport's worth of height is corrupt (mostly just white / missing) right there.  If I scroll down and then scroll back up slowly, the content is there, but if I try to view it by scrolling *down* to it, it's missing.

BUGGY:
 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008072302 Minefield/3.1a1pre

WORKS:
 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Here's a screenshot of the bug, viewed using the attached zipped testcase.

If I scroll down and then back up, then the central white area becomes populated with content, but if I take a screenshot at that point, the content immediately disappears.

The corrupt area varies slightly depending on how wide the browser is, too -- I tried making the browser about 1.5x as wide, and then the corruption started a little lower (partway through the first image after "Dolphin).
(In reply to comment #0)
> Steps to reproduce:
>  1. Load URL (or download attached zip file and load planet/planet.html)

Oops -- I just noticed the zip file failed to attach because it's too big (1.5 megs).

I've now posted the testcase at 
 http://people.mozilla.com/~dholbert/tests/448333/planet.html
and (for convenience) the zipped version at
 http://people.mozilla.com/~dholbert/tests/448333/planet.zip
Flags: wanted1.9.1?
Flags: wanted1.9.0.x?
This is apparently a cross-platform-bug -- I can reproduce a variant of this bug on Windows Vista. (using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1)

It manifests slightly differently on windows, but I'm pretty sure it's the same bug.

STEPS TO REPRODUCE on Windows:
 1. Load URL
 2. Ctrl-Shift-R (full reload). *Don't touch your mouse from here on out.*
 3. Press "end" key to jump to the last post
     --> RESULTS: the posts at the end of the page have completely blank bodies.
 4. Press "pageup" key until you find a post with text (or images) in it.
     --> RESULTS: there's a huge black block separating the blank posts from the normal posts.

Notes:
  - Certain events (e.g. moving the cursor across the window's scrollbar) seem to make the page fix itself.  After it's fixed, I can still return to a buggy state with a *full* reload (Ctrl-shift-R)
  - The positioning of the black block (described after step 4) seems to vary depending on how wide the window is.   So if you don't see the bug, try making the window skinnier.
    For example, if the window is at a width that makes the first post's title wrap just after the word install ("How to install [NEWLINE] and..."), then the black block appears partway through the post titled "KDE 4.1: good enough for ME".
Flags: blocking1.9.0.3?
OS: Linux → All
Hardware: PC → All
(In reply to comment #3)
>     For example, if the window is at a width that makes the first post's title
> wrap just after the word install ("How to install [NEWLINE] and..."), then the
> black block appears partway through the post titled "KDE 4.1: good enough for
> ME".

Here's a screenshot of the bug on windows, using the window-width described in this "for example".
Attachment #331603 - Attachment description: screenshot of bug → screenshot of bug on Ubuntu Linux
If I perform the STR from comment 3 on Linux, and if, at step 2, I alternate between pressing the "Home" and "End" keys, I get another weird manifestation of this bug: Chunks from the top of the page are still visible when I press "end", and chunks from the bottom of the page are still visible when I press "home".

This happens both on FF 3.0.1 and also on a fresh mozilla-central build (updated this morning).
Attached file testcase
It is my old friend, 16-bit widget coordinates with overflow: auto! Hello!
Assignee: nobody → vladimir
Attachment #337957 - Attachment is patch: false
Attachment #337957 - Attachment mime type: text/plain → text/html
Yeah, this is big-long again.  For some reason I thought we fixed that, so didn't bother checking spy++ for the actual widget size.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
hehe... FWIW, the SMIL bug is now long enough that I can reproduce this bug there as well in Linux, using basically the same process described in comment 5.
Specifically, I do this:
   1. Load bug 216462
   2. Press "end"
RESULTS: The contents of the CC list are still visible on the right side of the page, even though I'm now at the bottom of the page.  (though they disappear if I page up and then page down)

Build: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20081001 Minefield/3.1b1pre
Flags: wanted1.9.0.x?
Flags: blocking1.9.0.4?
Product: Core → Core Graveyard
Flags: wanted1.9.1?
You need to log in before you can comment on or make changes to this bug.