Trying to load Comcast.net results in endless loop, stopped by pressing "Esc"

RESOLVED DUPLICATE of bug 401709

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 401709
9 years ago
3 years ago

People

(Reporter: Weston Carloss, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/2008072803 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/2008072803 Minefield/3.1a2pre

When trying to load comcast.net, Minefield seems to get stuck in an endless loop trying to load http://www.comcast.net/browserupgrade/, which is the website that comcast redirects you to when it does not recognize your user agent string.

Reproducible: Always

Steps to Reproduce:
1.  Enter comcast.net in the address bar and press enter.

Actual Results:  
The status bar and favicon in the address bar rapidly flicker, showing that the browser is continually trying to load the page, but cannot.


This problem occurs both at home using an existing profile on Vista, and at work with a new profile on XP SP3.

Comment 1

9 years ago
Confirming based on comments on mozillazine.org.  I couldn't figure out from the comments if modifying the user agent to Firefox 3.0 loads the page (comcast.net) as normal or if modifying the user agent still directs to the browser upgrade page but does not have an endless loop of trying to load that page?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Version: unspecified → Trunk
With the UA change/modification to add 'Firefox/3.0' (no quotes required) the page loads normally, I saw no re-directs.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/2008072903 Minefield/3.1a2pre Firefox/3.0 ID:2008072903
Version: Trunk → unspecified
Assignee: nobody → english-us
Severity: major → normal
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us

Comment 3

9 years ago
How about investigating the endless loop first before contacting Comcast?  Are there any contacts at Comcast?  

And just to note, there is a big button on the page that will let you continue to view comcast's site.
If the UA change does fix it then this is 100% Tech Evangelism

Comment 5

9 years ago
"Fixes" as in not forwarded to the browser upgrade page.  Regardless, there is still an endless loop happening which shouldn't be.  That is what I would think should be investigated first before contacting comcast saying there is a problem but we aren't sure if it is a Firefox bug or your bad coding combined with bad user agent sniffing problem.

Comment 6

9 years ago
This sure looks like a dupe of bug 401709. When you kick bugs to TE, *please* do a search for dupes first.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401709
Every old browser that I tested (on Windows XP) showed this endless reloading behaviour so this is not a recent regression.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.