Need a way to choose bookmarks to pick for autocomplete

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Arun, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I organize my bookmarks into several folders. Bookmark helper/autocomplete/keyword search is all good, but there should be a way to restrict this feature to specific folders only. In other words, I want to be able to choose which folders the feature should not look into :)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
To me, this looks like a feature for an extension, at least for testing how popular this extension would be (and stay).
Confirming as an enhancement request.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Bookmarks → Location Bar and Autocomplete
Ever confirmed: true
QA Contact: bookmarks → location.bar
Version: unspecified → Trunk

Updated

9 years ago
Whiteboard: wontfix?

Updated

9 years ago
Duplicate of this bug: 433452

Updated

9 years ago
Duplicate of this bug: 440556
I don't think this would be effective. If you actually visit those bookmarks, they're going to show up in the location bar regardless.

Or are you asking to be to say: "never show bookmarks in folder X, even if they're in history"? if so, this isn't really a complete privacy solution, since anyone using that profile can browse your bookmarks, or search them via the Library, or search History via the sidebar, etc, etc.

Firefox 3.1 has a Private Browsing feature that might help somewhat, but from the sounds of it, will not totally help, since it doesn't yet have "private bookmarks", bookmarks that only show up while in private mode (IIRC there's a bug for this...).

I'm going to mark this as WONTFIX, since I think this wouldn't effectively "hide" the bookmarks.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix?
You need to log in before you can comment on or make changes to this bug.