SVG with TSPAN not work with styles: stroke and stroke-width

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: cristhiano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

In Firefox 2.0, this code work. But, with Firefox 3.0, the text is exploded when put styles stroke and stroke-with in same tspan.

Reproducible: Always

Steps to Reproduce:
1.Open this code in firefox
2.
3.
Actual Results:  
Text exploded

Expected Results:  
Four lines of text without exploded

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.0//EN" 
              "http://www.w3.org/TR/2001/REC-SVG-20010904/DTD/svg10.dtd">

<svg
   xmlns:svg="http://www.w3.org/2000/svg"
   xmlns="http://www.w3.org/2000/svg"
   xmlns:xlink="http://www.w3.org/1999/xlink"
   viewBox="0 0 434500 279400"
   width="100%" height="100%"
>

<g>

<text x="0" y="10000" font-family="Arial,Helvetica" font-size="8000px" text-anchor="left" font-weight="bold">
	<tspan x="0" dy="10000">Without stroke and stroke-width</tspan>
	<tspan x="0" dy="10000" style="stroke:#72706f;stroke-width:100;">With stroke and stroke-width</tspan>
	<tspan x="0" dy="10000" style="stroke:#72706f;">With stroke and without stroke-width</tspan>
	<tspan x="0" dy="10000" style="stroke-width:100;">Without stroke and with stroke-width</tspan>
</text>

</g>
</svg>
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general
You are using a stroke-width of 100 rather than the default of 1 and so the stroke-width of the characters is very large in one of the tspans.

What is the problem? On firefox 3 it looks like it is displaying correctly to me.
(Reporter)

Comment 2

10 years ago
Created attachment 331723 [details]
Picture of test

This is a picture for my test.
That's what I see. Why don't you think that is correct?
(Reporter)

Comment 4

10 years ago
Created attachment 331963 [details]
Correct in Firefox2

This is a correct view of file.
I think this is fixed in the current trunk. Please confirm.
Closing as WORKSFORME on current trunk. If that's not the case then feel free to reopen, please include the build version copied from from help->about if you do.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.