Overflow's value can affect a table's background color [BG]

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
19 years ago
17 years ago

People

(Reporter: jmraker, Assigned: karnaze)

Tracking

({css2, testcase})

Trunk
mozilla1.0.1
x86
Linux
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl], URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Using Linux 2000070608 nightly build.

Actual Results:
  The background color of a table body is ignored if overflow:none.
  In the testcase http://www.mwaccess.net/~john/tc/tc20.html
  The first 2 tables have overflow:auto and a red background, the 3rd one is
overflow:none with a cyan background.

Expected Results:
  Overflow should not affect whether a background color is used.

Comment 1

19 years ago
Confirmed on Linux 2000070608. Going to attach reporter's test case.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
Created attachment 11151 [details]
Overflow testcase

Comment 3

19 years ago
Forgot to CC: myself. Sorry for the spam.

Comment 4

19 years ago
over to style system
Assignee: asa → pierre
Component: Browser-General → Style System
QA Contact: doronr → ckritzer

Comment 5

19 years ago
Created attachment 13747 [details]
Reduced testcase with correct overflow value (none is illegal, use hidden)

Comment 6

19 years ago
The style data is correct. My guess is that either the table cell frame is doing 
the wrong thing and the (auto|scroll) cases work because they use a scroll 
frame.

Over to tables for deeper analysis.
Assignee: pierre → karnaze
Keywords: css2
Summary: css2, Overflow's value can affect a table's background color → Overflow's value can affect a table's background color
Summary: Overflow's value can affect a table's background color → Overflow's value can affect a table's background color [BG]

Updated

18 years ago
Keywords: testcase
(Assignee)

Comment 7

18 years ago
Moving to m1.0.1.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1

Comment 8

18 years ago
Moving to correct QA Contact - here ya go Ian!
QA Contact: ckritzer → ian
QA->amar, this is a tables bug
Component: Style System → HTMLTables
QA Contact: ian → amar

Updated

17 years ago
Whiteboard: [awd:tbl]
(Reporter)

Comment 10

17 years ago
I'm marking this bug WORKS FOR ME.
The backgrounds of the testcases are ok, but a few borders render oddly and
change when clicking on the table cells.  If that's background related, then
re-open.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.