Major performance regression with animated background

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Renaud Manus, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9) Gecko/2008060510 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9) Gecko/2008060510 Firefox/3.0

http://www.superchessengine.com/toga_ii.htm has an animated background
that causes Mozilla 3.0 to consume ~100% of cpu time and causes the
system to be mostly unresponsive.

Firefox 2.0.0.14 doesn't have the problem.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.superchessengine.com/toga_ii.htm
2.
3.
I can reproduce this on Windows but only on one computer (with an AMD Athlon processor).
Keywords: regression
OS: SunOS → All
Hardware: Other → All
Version: unspecified → Trunk

Comment 2

10 years ago
Works for me, Firefox 3.0.1 on Ubuntu 8.04 with Intel Core2 CPU.
(Reporter)

Comment 3

10 years ago
Still reproducible with 3.0.1 on Solaris Nevada build 94 with AMD Turion64 X2. 

Firefox doesn't consume 100% of cpu but it generates enough load for Xorg to
consume most of the cpu time.

Comment 4

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB5

~50% CPU usage

Comment 5

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090925 Shiretoko/3.5.4pre GTB5

~40% CPU usage
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You may also wish to try with the latest Firefox 4 beta, http://www.mozilla.com/en-US/firefox/all-beta.html.
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.