Print Selection affected by clumsy CSS

RESOLVED DUPLICATE of bug 428109

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 428109
10 years ago
8 years ago

People

(Reporter: Billy Estes, Unassigned)

Tracking

1.9.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I highlighted the section about check dates to the bottom of page only got header and footer

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Using Firefox 3.0.1 on Linux;  the selection prints although it's
extremely small, about 1x1 cm.  If I comment out:
@import url("/irs/cda/common/styleSheets/styles-gecko.css");
I get a normal print result, which suggests some error in the
style sheet?

Comment 2

10 years ago
Created attachment 331748 [details]
URL without said stylesheet

Comment 3

10 years ago
Created attachment 331752 [details]
Testcase

It's the following rule in that stylesheet that causes the problem:

@media print {
	div.headerBar{display:block;background: #001E5A;width:10000px;padding-top:12px;padding-right:1200px;}
}

Comment 4

10 years ago
Specifically, it's "width:10000px" that causes the problem.
Note that it's only a problem when printing a selection, not when
printing the whole page.  I'm guessing we try to fit that width
to the page width and thus everything is scaled down?
Component: General → Printing
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → printing
Hardware: PC → All

Comment 5

9 years ago
This also happens on http://www.volunteercalgary.ab.ca whenever you select anything on any page. It doesnt have that stylesheet problem though...

Comment 6

8 years ago
The page http://www.irs.gov/irs/article/0,,id=180250,00.html has changed.  Only the static Testcase attachment 331752 [details] is relevant.

Disabling All Styles with the Webdeveloper Toolbar extension is a workaround for the bad CSS on this page.

The Volunteer Calgary site throws errors including XML parsing errors.
http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.volunteercalgary.ab.ca%2F

Old subject was: "print selection dose not print"

One way to solve most of the Print Selection issues would be to disable all formatting and simply print out the HTML in the default font.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: print selection dose not print → Print Selection affected by clumsy CSS
Version: unspecified → 1.9.0 Branch
(In reply to comment #6)
> One way to solve most of the Print Selection issues would be to disable all
> formatting and simply print out the HTML in the default font.

That's good as a workaround, but I think it would break too many things to be a general solution for print selection.  e.g. it'd break bold/italic/small-caps/superscript/subscripts, all of which could be a meaningful part of the content.  It'd also break "float:left" images with text flowing around them, content that's inserted via ":before" and ":after", etc.

Updated

8 years ago
Duplicate of this bug: 335025

Updated

8 years ago
Duplicate of this bug: 435051

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428109
You need to log in before you can comment on or make changes to this bug.