Closed Bug 448558 Opened 11 years ago Closed 11 years ago

Deleting multiple mails from Junk ends in "The current command did not succeed" (IMAP)

Categories

(MailNews Core :: Backend, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.1a2

People

(Reporter: standard8, Assigned: Bienvenu)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached file IMAP log (obsolete) —
Steps to repeat:

1) Have some mails in a Junk folder on IMAP.
2) Go through the folder, deleting all the emails one by one.
3) Wait for the transactions to complete in the background.
4) The follow error is displayed:

"The current command did not succeed. The mail server responded: Error in IMAP command received by server".

This has probably started in the last 1-2 weeks.

Attaching an imap protocol log
Flags: blocking-thunderbird3+
it looks like we think your server supports condstore, when it doesn't. It may be related to all the dropped connections I saw...
(In reply to comment #1)
> it looks like we think your server supports condstore, when it doesn't. It may
> be related to all the dropped connections I saw...
> 
I've seen these without all the dropped connections as well - i.e. upstairs (and currently) where the network appears to be fine.
cool - a log without all the dropped connections would be helpful, to avoid the noise...
Attached file IMAP log v2
Hopefully a slightly smaller file...
Attachment #331754 - Attachment is obsolete: true
thx Mark, it's helpful to see what those two have in common.  In both case, we're doing a NOOP, and we're also doing a quotaroot after the NOOP, which is, I think, a sign of a lite select, i.e., a select where we don't do a full syn) (we shouldn't be doing the quotaroot at all, but I think that's a pre-existing issue)
Attached patch possible fixSplinter Review
Can you try this patch, Mark? I haven't been able to reproduce this problem, but the network is pretty flakey.
Assignee: nobody → bienvenu
Status: NEW → ASSIGNED
Getting same message with emptying other folders, not just with junk folder. Also, when compacting folders (at least once or twice). This started on Sunday night's build for the Mac. Had to go back to 20080725 build to fix it.
Comment on attachment 331801 [details] [diff] [review]
possible fix

I think what's happening here is that we're running into a case where flag state is empty, but there is a message header in the folder (I was able to reproduce that). In any case, we shouldn't be adding CHANGEDSINCE unless we're using condstore.
Attachment #331801 - Flags: superreview?(neil)
Attachment #331801 - Flags: review?(bugzilla)
Product: Core → MailNews Core
Comment on attachment 331801 [details] [diff] [review]
possible fix

This seems to fix it. r=me
Attachment #331801 - Flags: review?(bugzilla) → review+
Duplicate of this bug: 448455
David, Bug 448455 isn't the same thing at all! Maybe the same code is responsible for it, you know.
I believe the only difference is that you're getting a different error message back from the server, but that's because you have a different server. I believe the same code is responsible for it.
Not sure, because I don't remove/delete any mail to the junk folder at all. It happens without relation to that. But maybe it's indeed the same thing, will try to create a log and compare to the one from here...
Attachment #331801 - Flags: superreview?(neil) → superreview+
fix checked in.

the problem is not at all specific to the junk folder - it just has to do with deleting all (or close to all) messages in a folder...
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
OS: Mac OS X → All
Hardware: PC → All
Target Milestone: --- → mozilla1.9.1
Target Milestone: mozilla1.9.1 → mozilla1.9.1a2
You need to log in before you can comment on or make changes to this bug.