MNG supports neither Chromaticity correction nor ICC profiles

RESOLVED WONTFIX

Status

()

Core
ImageLib
P3
normal
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: sicking, Assigned: tor)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

The supplied URL goes to a page in the libmng testsute. The buttom image is a
test for Gamma correction and ICC profiles. The different pictures of the
flowsers should NOT look the same.

tested with build 2000-07-07-20 on Win98SE
Blocks: 18574
Sorry, a bit more investigation shows that Gamma seem to work but not
chromaticity and ICC profiles. Updating Summary.
Summary: MNG dosn't support Gamma correction and ICC profiles → MNG dosn't support Chromaticity correction and ICC profiles
(Assignee)

Comment 2

17 years ago
libmng has support for lcms, which performs these operations.
The lcms code is currently c-99, so would require some grunt
work to compile with ansi-c compilers.  The bigger issue is
that lcms is licensed under the LGPL.  Adding mitchell for
her opinion on the licensing issue.

     lcms homepage - http://www.abaforum.es/martim/lcms.htm
OS: Windows 98 → All
Hardware: PC → All

Comment 3

17 years ago
LGPL is compatible with the MPL and the NPL - it's even compatible with
proprietary licenses. Moz.org may not want code under this license as part of
the main tree (for that you'd need to ask them) but I can't imagine that there
would be a problem with linking to it as an external library...

The requirements of the LGPL basically just amount to letting the user know they
can get the source, and using dynamic linking so they can replace the library
with a modified version if they choose to. Moz uses dynamic linking anyway, and
I'm sure the release notes will contain a whole bunch of legal stuff already.

The only thing you have to worry about if using it as an external library is
detecting at runtime whether it's present on the target system and using it only
if so.
(Assignee)

Comment 4

17 years ago
I doubt that any significant percentage of unix boxes have lcms installed,
and can pretty much guarantee that no win32/macos boxes will have it lying
around.  Thus depending on an external library isn't practical.

Possible alternate approach: Xcms on unix/X11, ColorSync on win32, and
??? elsewhere.

Comment 5

17 years ago
Doh. Yes, I'm too used to debian where depending on an external library is as
simple as "Recommends: lcms"

That doesn't rule out using it though; so long as dynamic linking is used and
the appropriate legalese appears in the release notes, it's perfectly
permissible to include it in the mozilla installation bundle. So the question is
- what is moz.org's position on bundling LGPL'd code?

Stuart.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: --- → Future
(Assignee)

Comment 6

17 years ago
Notes for future reference:

X11: Xcms

  man -k Xcms

MacOS: ColorSync
 
http://developer.apple.com/techpubs/macos8/MultimediaGraphics/ColorSyncManager/colorsyncmanager.html

Win32: ICM 2.0

  http://msdn.microsoft.com/library/psdk/icm/icmstart_5i91.htm

Updated

17 years ago
QA Contact: elig → tpreston

Comment 7

16 years ago
Updated Mac OS ColorSync Manager URI:
http://developer.apple.com/techpubs/macosx/Carbon/graphics/ColorSyncManager/colorsyncmanager.html

Comment 8

16 years ago
It's a little easier to see this bug at:

http://www.libmng.com/MNGsuite/anke_simi_img.html
Could we perhaps use lcms now that the mozilla tree can handle non-MPL/NPL 
licencies? The libart library that is LGPLed lives happily in
mozilla/other-licenses/libart_lgpl

Updated

15 years ago
Blocks: 119597

Comment 10

15 years ago
This bug is caused by an out of date version of libmng. update to a version more
recent than 1.0.4 to resolve this problem. this bug is found on the libmng website.

Comment 11

15 years ago
*** Bug 181676 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
opps. sorry about posting the other bug as a duplicate of this bug. these bugs 
and the solution may be related but theyare not the same.

Comment 13

14 years ago
Adding dependency on bug 181676 per comment 10.
Depends on: 181676

Updated

14 years ago
Summary: MNG dosn't support Chromaticity correction and ICC profiles → MNG supports neither Chromaticity correction nor ICC profiles

Comment 14

14 years ago
comment 10 is mistaken as such the reason for dependancy on bug 181676 should
not be due to my mistaken comment 10, but it should be left as a dependancy
because it would be unwise to try to fix this shortly before libmng 1.0.5 final
is released as doing that may cause problems when we update it.

Comment 15

14 years ago
using build 2003030908 on Win2k, I crash when displaying the URL
http://www.libmng.com/MNGsuite/anke_diff_img.html : TB17913211K.
Perhaps a regression from new libmng 1.05, bug 181676 ?
Keywords: crash, stackwanted
Whiteboard: TB17913211K
this bug has nothing to do with a crash. Please file a new bug on that
Keywords: crash, stackwanted
Whiteboard: TB17913211K
Works For Me, Moz 1.3 20030312, Win95.  The colors all look correct, so color
management is working properly.  Perhaps this bug should be closed.  Glenn

Comment 18

14 years ago
Using a 4/28 build at the URL in comment 8, I still see a problem with the
second set of images.  "If the image at center-bottom looks as strange as the
one on the left, your software *does not* handle ICC profiles."
Oops, you're right.  The images in the main URL look correct, but the ones
in comment #8 display swapped color channels.   So Moz 1.3 doesn't WFM.  Glenn
"The images in the main URL look correct" is actually incorrect behaviour.
To pass the test, they should appear with swapped colors.  Sorry.

Updated

14 years ago
No longer blocks: 18574
Depends on: 18574

Comment 21

12 years ago
*** Bug 288727 has been marked as a duplicate of this bug. ***
Since bug # 18574 has been marked WONTFIX, this one should also be marked WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.