"(edit)" links should focus the text box and select all text in them

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Jesse Clark, Assigned: Guy Pyrzak)

Tracking

3.1.4
Bugzilla 3.2
Bug Flags:
approval +
approval3.2 +

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
When a user clicks the "(edit)" link for a field such as Assigned To or QA Contact, they probably want to begin typing in the field without having to select it first. We should select the text automatically.

The "(edit)" link also appears for other fields, such as short_desc, which are more likely to be refined than replaced, so we may not want to select it in that case.

Comment 1

10 years ago
pyrzak wants this for 3.2. If it's a minor code change, that's fine.
Assignee: ui → guy.pyrzak
Severity: normal → enhancement
Target Milestone: --- → Bugzilla 3.2
Version: 3.3 → 3.1.4
(Assignee)

Comment 2

10 years ago
Created attachment 336394 [details] [diff] [review]
patch v1

Comment 3

10 years ago
Comment on attachment 336394 [details] [diff] [review]
patch v1

Did you want me to review this?
(Assignee)

Comment 4

10 years ago
Comment on attachment 336394 [details] [diff] [review]
patch v1

sure, i guess reviews are a good idea :D
Attachment #336394 - Flags: review?(mkanat)

Comment 5

10 years ago
Comment on attachment 336394 [details] [diff] [review]
patch v1

This just focuses the field, it doesn't select the text, which is what this bug wanted, but focusing it is better than nothing, for sure! And it makes total sense. We can have another bug for text selection where that makes sense, possibly?
Attachment #336394 - Flags: review?(mkanat) → review+

Updated

10 years ago
Flags: approval3.2+
Flags: approval+
Summary: "(edit)" links should select text → "(edit)" links should select focus the text box

Updated

10 years ago
Summary: "(edit)" links should select focus the text box → "(edit)" links should focus the text box

Comment 6

10 years ago
I filed bug 453604 for the text-selecting.

Updated

10 years ago
Summary: "(edit)" links should focus the text box → "(edit)" links should focus the text box and select all text in them

Updated

10 years ago
Duplicate of this bug: 453604
(Assignee)

Comment 8

10 years ago
Created attachment 336811 [details] [diff] [review]
v1.1
Attachment #336394 - Attachment is obsolete: true
Attachment #336811 - Flags: review?

Updated

10 years ago
Attachment #336811 - Flags: review? → review+
(Assignee)

Comment 9

10 years ago
Created attachment 336916 [details] [diff] [review]
patch had a bad line number here is what i actually checked in
Attachment #336811 - Attachment is obsolete: true
(Assignee)

Comment 10

10 years ago
Checking in js/field.js;
/cvsroot/mozilla/webtools/bugzilla/js/field.js,v  <--  field.js
new revision: 1.9; previous revision: 1.8
done
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

10 years ago
3.2 commit
Checking in js/field.js;
/cvsroot/mozilla/webtools/bugzilla/js/field.js,v  <--  field.js
new revision: 1.8.2.1; previous revision: 1.8
done
You need to log in before you can comment on or make changes to this bug.