Want ability to take individual accounts off-line

RESOLVED DUPLICATE of bug 312619

Status

--
enhancement
RESOLVED DUPLICATE of bug 312619
10 years ago
6 years ago

People

(Reporter: nelson, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

With current mailnews, once you login to a mail or news server, you're
on line with that server until you close the mail/news client (or, if
you're in SeaMonkey, you can take the whole client off-line).  If you've
enabled checking for new messages every N minutes, then once you go on-line
and login for an account, it will keep checking as long as your client is
alive.  

I want a way to take an individual mail or news account off line, to make 
it stop checking for updates, until I put it back on-line again.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312619
Whether or not this is a DUP depends a on the use case here.  If the use case is "don't want to be distracted by personal email at work", that's a little bit different (and that use case is one that I certainly have).  In particular, if that's the use case, I'm not sure going offline is exactly what's desired here as much as simply "stop notifying for new mail".  Nelson, what did you have in mind when you filed?
(Reporter)

Comment 3

10 years ago
Dan,
Mostly I want to be able to stop it from *trying* to contact the imap/pop
server and check for new email.  Those events trigger password prompts or
other sorts of interactions (errors of various sorts) that I just don't
want to deal with for periods of time.  

If I was using FF and TB instead of SM, I would just exit TB and leave FF
running.  But that's not much help for SM users.  Also, I'd like to be 
able to just disable the accounts for the servers that have troubles, and 
leave the accounts for the servers that don't have troubles running.

The message is: stop all asynchronous activity, activity that happens 
for some reason other than I clicked, that has the potential to require
me to intervene (entering passwords, or dealing with errors) that 
interrupt the work I'm doing.
No, this is not a duplicate of bug 312619.
That bug just wants to stop displaying modal dialogs when an attempt to 
connect to a server fails.  
I want to STOP TRYING to connect to a server, even when it would SUCCEED.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: 680056
No longer blocks: 680056
Status: REOPENED → NEW

Comment 5

6 years ago
I disagree with the non-dupe.

I fail to see how the distinction you make is relevant for this not being a duplicate of bug 312619.  As far as I can see, even if the motivations are different (pretty clearly laid out in comment 0), the solution is not different - you want an account that is offline, that gets no new mail and no interaction with the server.

(In reply to Nelson Bolyard (seldom reads bugmail) from comment #4)
> No, this is not a duplicate of bug 312619.
> That bug just wants to stop displaying modal dialogs when an attempt to 
> connect to a server fails.  
> I want to STOP TRYING to connect to a server, even when it would SUCCEED.

and "I want a way to take an individual mail or news account off line, to make it stop checking for updates, until I put it back on-line again."

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312619
You need to log in before you can comment on or make changes to this bug.