Flash objects are always on the top of the web page

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Ming Tang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

When I went to a site with Flash, the Flash object always came on the top, even elements that has Z-index values higher than one, and even objects generated by Firefox extensions.

Reproducible: Always

Steps to Reproduce:
1.Go to a site with Flash, or make a page that embeds Flash
2.The Flash objects always came on the top even if you put an element that has Z-index values higher that one.
Actual Results:  
The Flash object always come on the top regardless the Z-index of other elements.

Expected Results:  
The Flash object should in their normal Z-index.

Clicky Web Analytics support said Flash object will on the top on Linux, so you won't see the dropdown menu. However, it also happened on Windows
When I went to Zango and my WOT extension said the site is dangerous, the Flash objects were on the top.
You must use a flash palyer which supports windowless mode.
That is on linux currently only the latest flash10 beta but i don't know which plugin version you are using because you didn't add the required information.
Please always include the plugin version if you report a bug about plugins.
Z-index works great on win32 with flash player 9.X if for example wmode transparent is set.

marking wfm

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: Disability Access → General
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.