"TEST-UNEXPECTED-FAIL | test_nsAbManager2.js | Unexpected directory moz-aboutlookdirectory://oe/AAAAAMCRrdNRnc8RpKkAqgBH-qQB found in address book list

RESOLVED FIXED in seamonkey2.0a1

Status

SeaMonkey
MailNews: Address Book & Contacts
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Blocks: 2 bugs, {regression})

Trunk
seamonkey2.0a1
x86
Windows 2000
regression
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008080203 SeaMonkey/2.0a1pre] (home, optim default) (W2Ksp4)

|make check| fails (on this test only).
(Assignee)

Comment 1

10 years ago
Created attachment 332046 [details]
test_nsAbManager2.js.log
(Assignee)

Updated

10 years ago
Blocks: 448861
(Assignee)

Updated

10 years ago
Severity: normal → major
No longer blocks: 448861
So, I think there are potentially two ways to fix this bug, but bear with me:

1) Add special casing similar to:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mailnews/addrbook/test/unit/test_nsAbManager2.js&rev=1.7&mark=125-127#110

2) Disable the Outlook/Outlook Express link in abSetup.js

I think item 2 is the best option. Although the first option is attractive, there are various problems I believe; firstly the user can set up OE with multiple books, secondly, the data (e.g. naming) is going to vary.

In the OS X case I've been able to get away with this, as there is only one top-level address book (and the default name/items are controlled by TB), and I don't do anything below the top-level checking wrt OS X link.

I think in the Outlook (Express) case this won't work because of the way the interface is constructed. I'm sure Neil will tell me if I'm wrong.

Comment 3

10 years ago
I've never seen multiple OE address books reflected in SeaMonkey, although I only tried once, and I may not have configured OE correctly.

I also think that the URI you get in the OE case is unpredictable.
(Assignee)

Comment 4

10 years ago
Fwiw,

I'm discovering this O(E) feature;
I have never used O(E), maybe started it "once" only.

***

Testing with new (dumb) profiles:

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008072102 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008072203 Shredder/3.0a2pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008080200 Shredder/3.0b1pre] (nightly) (W2Ksp4)

No O(E) AB.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/2008080100 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

I get an additional "OE Contacts" AB, (before the two usual ABs).

PS: Is this a (new) SeaMonkey only feature !?

***

In "Start > Programs > Accessories > Address Book", [I'm "discovering" this too...]
I see 2 ABs, named "Shared Contacts" and "Contacts: Main Identity".

If I add contacts to them, SM merges them all into its "OE Contacts" AB.

NB: In SM, I can edit these cards, but as soon as I select another AB and come back, the changes are lost :-/

***

Not knowing (yet) how all this is supposed to work, I can't suggest what I might would like it (= the test, ...) to do.
(In reply to comment #4)
> [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre)
> Gecko/2008080100 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
> 
> I get an additional "OE Contacts" AB, (before the two usual ABs).
> 
> PS: Is this a (new) SeaMonkey only feature !?

Enabling it by default is a new SeaMonkey feature. It has been in SM & TB for a very long time.

> Not knowing (yet) how all this is supposed to work, I can't suggest what I
> might would like it (= the test, ...) to do.

We have no control over what is in the Outlook / OE address books for unit tests.

For the Mac OS X Address Book I've got away with it because the interface settings are stable (uri etc) and therefore consistent test results.

For the Outlook / OE address books I don't think we've got this stability, therefore we should just disable them in the unit tests.
(Assignee)

Comment 6

10 years ago
(In reply to comment #2)
> 1) Add special casing similar to:

Is there always at least an (empty) O(E) AB on Windows ?
(If so, may be we could test it exists, without verifying its uri.)

> 2) Disable the Outlook/Outlook Express link in abSetup.js

Or would there be a preference to (temporarily) disable ?

(In reply to comment #5)
> therefore we should just disable them in the unit tests.

If this is the only solution, let's do that.
(In reply to comment #6)
> (In reply to comment #2)
> > 1) Add special casing similar to:
> 
> Is there always at least an (empty) O(E) AB on Windows ?
> (If so, may be we could test it exists, without verifying its uri.)

Which would make the existing tests more awkward.

> > 2) Disable the Outlook/Outlook Express link in abSetup.js
> 
> Or would there be a preference to (temporarily) disable ?

I haven't got time to find it now, basically mailnews.js, look for suite specific outlook express stuff that I think Neil added. Need disabling via the prefs api probably in head_*.js (in the address book) or abSetup.js (the latter is probably more appropriate).
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > Is there always at least an (empty) O(E) AB on Windows ?

Bug 436794 comment 9:
{{
neil@parkwaycc.co.uk   2008-06-15 13:25:05 PDT

OK, so it looks like the OE address book is always available in Windows, but
the Outlook address book cannot be created if Outlook isn't installed.
}}

> > (If so, may be we could test it exists, without verifying its uri.)
> 
> Which would make the existing tests more awkward.

I don't know if it's worth it: I wanted to suggest it only...

> > Or would there be a preference to (temporarily) disable ?

<http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/mailnews/mailnews.js&rev=HEAD&mark=3.322>
Blocks: 436794
Keywords: regression
(Assignee)

Updated

10 years ago
Blocks: 452942
(Assignee)

Updated

10 years ago
Blocks: 452939
(Assignee)

Comment 9

10 years ago
Created attachment 336238 [details] [diff] [review]
(Av1) <abSetup.js>
[Checkin: Comment 10]

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b1pre) Gecko/20080830184151 SeaMonkey/2.0a1pre] (home, debug default) (W2Ksp4)

Fixes both this bug and bug 452939.

*****

Fwiw, <http://en.wikipedia.org/wiki/Windows_Address_Book>.
Assignee: mail → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #336238 - Flags: superreview?(neil)
Attachment #336238 - Flags: review?(bugzilla)
(Assignee)

Updated

10 years ago
QA Contact: addressbook → addressbook
Target Milestone: --- → seamonkey2.0alpha

Updated

10 years ago
Attachment #336238 - Flags: superreview?(neil) → superreview+
Attachment #336238 - Flags: review?(bugzilla) → review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checked in, changeset id: 239:386bea07037d
Keywords: checkin-needed
(Assignee)

Updated

10 years ago
Attachment #336238 - Attachment description: (Av1) <abSetup.js> → (Av1) <abSetup.js> [Checkin: Comment 10]
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.