Back navigation problem using My Yahoo homepage

RESOLVED DUPLICATE of bug 215405

Status

()

--
minor
RESOLVED DUPLICATE of bug 215405
10 years ago
10 years ago

People

(Reporter: fpilot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I am having navigation problems with the new My Yahoo homepage updated by Yahoo 7/15/08 that didn't exist with the previous version.  Specifically, when I navigate back to the home page after reading a page module item, instead of returning to the module area of the home page that I was viewing, I am returned to the top of the home page.  NOTE: This problem is does NOT occur with other web pages and is isolated to My Yahoo homepage.

According to Yahoo support, this is an issue with Firefox per this response I received from Yahoo support on 8/1/08:

Thank you for writing to My Yahoo!.

I understand that you're having trouble with your browser returning you
to the top of your My Yahoo! page when using the back button to come
back from a visited link. Our engineers have researched this issue
thoroughly and determined that it is isolated to Mozilla Firefox, and
outside of our control.

I apologize for any inconvenience.

Thank you again for contacting My Yahoo!.

Regards,

Jules

My Yahoo! Customer Care

For assistance with all Yahoo! services, please visit:

   http://help.yahoo.com/

New and Improved Yahoo! Mail - better than ever!


Reproducible: Always

Steps to Reproduce:
1.Open My Yahoo homepage at http://cm.my.yahoo.com/
2.Scroll down page to a module. 
3.Click on module article.
4.Click back navigation arrow or mouse back navigation button.
Actual Results:  
Returned to top of My Yahoo homepage on back navigation instead of area farther down the page containing viewed module item.

Expected Results:  
To be returned to area of My Yahoo homepage with module containing viewed item upon back navigation.

Returned to area of My Yahoo homepage with module containing viewed item upon back navigation command.

Comment 1

10 years ago
I confirm this. Can you try in Safe Mode (http://support.mozilla.com/en-US/kb/Safe+Mode)?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

10 years ago
That was confirmed on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/2008080203 Minefield/3.1a2pre
Severity: normal → minor
(Reporter)

Comment 3

10 years ago
Issue also occurs in Firefox Safe Mode.
(Reporter)

Comment 4

10 years ago
Note this problem is confined to back navigation to My Yahoo! homepage after clicking on an article on the homepage.  It does not replicate with forward navigation to an article selected on the My Yahoo! home page; the browser returns to the scrolled area of the article page in forward navigation.

Comment 5

10 years ago
Problem fix discovered that wasn't previously available.  Place modules in right (not left) column using change layout function of My Yahoo! home page. Suggest changing status to resolved.

Comment 6

10 years ago
Disregard comment #5.  Issue is recurring again.

Comment 7

10 years ago
My Yahoo! doesn't want its pages cached, and I think Firefox can't restore the scroll position because the pages don't go into the fastback cache.  (FWIW, Opera reloads the page, not from cache, but then scrolls to the previous position.)

The http headers:
Expires: Thu, 01 Jan 1995 22:00:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, private, post-check=0, pre-check=0
Pragma: no-cache

Comment 8

10 years ago
This is a dupe of bug 215405

Comment 9

10 years ago
Here's Yahoo's status on the issue as of 10/30/08:

Thank you for writing to My Yahoo!.

We understand your concerns.  We are working to resolve the technical
issue with your browser not returning to the same position on the page
when navigating back to it as soon as possible.  While we cannot provide
you with an accurate estimate of how long this resolution will take, you
can rest assured that we hope to have the issue resolved soon.  We
appreciate your patience.

Thank you again for contacting My Yahoo!.

Regards,

Jules

My Yahoo! Customer Care

Comment 10

10 years ago
Note that this problem is confined to the My Yahoo! home page and not other Yahoo pages.
OK, marked as dupe.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 215405
You need to log in before you can comment on or make changes to this bug.