Closed Bug 448922 Opened 13 years ago Closed 11 years ago

Text in location bar overflows its content box

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mvanier, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

I've been trying to increase the font size in the URL bar.  I created a userChrome.css file with the following:

#urlbar {
   font-family: monospace !important;
   font-size: 18 pt !important;
}

The font family was changed to monospace (indicating that this is the correct CSS identifier for the URL bar) but the font size wasn't changed.


Reproducible: Always

Steps to Reproduce:
1. Edit the userChrome.css file as described above.
2. Restart Firefox.
3. Gaze in wonder at the unchanged font size in the URL bar.
Actual Results:  
The font size does not change.

Expected Results:  
The font size should increase to the specificed size.
This: 

textbox
{
    font-family: verdana !important;
    font-size: 14px !important;
}

?
(In reply to comment #1)
> This: 
> 
> textbox
> {
>     font-family: verdana !important;
>     font-size: 14px !important;
> }
> 
> ?
> 

Yes, that works.  Thank you _so_ much!  One other thing: at larger font sizes, the fonts overflow the URL bar.  Is there a way to make the text area itself larger?

Sorry to ask what must seem like stupid questions, but I can't find any general dictionary of firefox CSS properties, so it's pretty much guesswork.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Not sure what you mean, but there is a resizer between the URL bar and the searchbar, so that you can drag it wider. You can also give the URL bar its own toolbar. View -> Toolbars -> Customize -> Add New Toolbar, and then you can drag the locationbar onto the new toolbar (while the Customize window is open).

In case I misunderstand your problem, can you add a screenshot (with the Add an attachment link or with http://www.imageshack.us/ )?
(In reply to comment #3)
> Not sure what you mean, but there is a resizer between the URL bar and the
> searchbar, so that you can drag it wider. You can also give the URL bar its own
> toolbar. View -> Toolbars -> Customize -> Add New Toolbar, and then you can
> drag the locationbar onto the new toolbar (while the Customize window is open).
> 
> In case I misunderstand your problem, can you add a screenshot (with the Add an
> attachment link or with http://www.imageshack.us/ )?
> 

Yeah, I should have been more specific about the problem.  The width of the URL bar is fine (thanks for the tip about resizing it -- great feature!).  It's the _height_ of the URL bar that I'd like to change.  For instance, if you have a really big font (say 24 px, way more than I want), then the letters are too big to fit into the box, so they overflow and it looks ugly.  The solution would be to have a way to increase the height of the bar so that it's big enough to hold the text you want.  A _really_ smart URL bar would be able to expand itself optimally to fit the text inside, but I don't expect that any time soon.  I'd be happy to just be able to adjust it manually.

Thanks again for all your help!

Mike
In this screenshot you can see that it should expand itself in the height:
http://img368.imageshack.us/img368/4687/urlbarff4.png
But maybe you are using a theme?
(In reply to comment #5)
> In this screenshot you can see that it should expand itself in the height:
> http://img368.imageshack.us/img368/4687/urlbarff4.png
> But maybe you are using a theme?
> 

Yeah, that's exactly what it _should_ be doing but isn't.  I'm using the default theme on Mac OS X.  Maybe this should be reclassified as an actual bug?  Or maybe it's just a limitation of the Mac OS X default theme?

Anyway, thanks again for your help.  I'm impressed that this functionality is in FF.

Mike
Sadly I have no Mac, so I can't test it, but Kevin Gerich landed the Mac theme, so maybe he knows more about it. I'll reopen the bug for now.
Blocks: proto
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
I can confirm this behavior with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/2008080302 Minefield/3.1a2pre ID:2008080302. See the upcoming screenshot.
Status: UNCONFIRMED → NEW
Component: General → Theme
Ever confirmed: true
QA Contact: general → theme
Hardware: Macintosh → All
Version: unspecified → Trunk
Summary: can't change urlbar font size → Text in location bar overflows its content box
Dao, do we have a fixed height due to the rounded corners and the identity button? If yes, it should also happen on Windows.
Looks like only OS X related. Works fine with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008080504 Minefield/3.1a2pre
Pinstripe uses fixed-height background images for the location bar.
See <http://mxr.mozilla.org/mozilla-central/source/browser/themes/pinstripe/browser/urlbar/>.
Pinstripe can get away with this since accessibly is handled in OS X with a full screen zooming feature, instead of making widgets individually larger, like in windows.
Depends on: 482086
should be fixed by now
Status: NEW → RESOLVED
Closed: 13 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.