If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Every word is marked as being spelled wrong.

VERIFIED INVALID

Status

Camino Graveyard
General
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Daniel Folsom, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.14) Gecko/20080512 Camino/1.6.1 (like Firefox/2.0.0.14)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.14) Gecko/20080512 Camino/1.6.1 (like Firefox/2.0.0.14)

Every so often, seemingly randomly, Camino will mark all the words I type as having incorrect spelling (regardless of whether they actually are incorrect); the problem is only (temporarily) resolved by restarting.

Reproducible: Couldn't Reproduce
(Reporter)

Comment 1

9 years ago
When I try to check the spelling language (by control-clicking and going to "Spelling Language") - nothing comes up, no languages are visible.

Comment 2

9 years ago
Hm, this sounds like it's probably an OS-level problem with the spelling service, since we build that list by directly asking the OS for supported languages.

Please download and run:
http://escapedthoughts.com/camino/CaminoDiagnostics.zip
and use the "Add an attachment" link above to attach the file it creates here.
(Reporter)

Comment 3

9 years ago
Created attachment 332127 [details]
Added per recommendation

Comment 4

9 years ago
Nothing interesting being logged by the OS, unfortunately. I double-checked the code that would mark a word as incorrect, and it's also a straight pass-through to the OS, with no state at our end that could get messed up; sharedSpellChecker must be returning nil, which we can't control. The only thing we could do would be to make the failure case mark nothing as incorrect rather than everything, but that doesn't really address the underlying problem (and is arguably worse, since then there's no obvious sign that spell-check isn't working any more).

The only thing that I can think of other than this being an OS bug is that perhaps you have a version of Flash with the file-descriptor leak, and this is a symptom of running out of file descriptors, so I'd suggest making sure you have the latest version of the Flash plugin.

If you still have this problem after making sure you have the latest Flash, I'd recommend filing a bug with Apple (<http://bugreport.apple.com>), since if it's a problem with NSSpellChecker they are the only ones who can investigate and fix it.

Closing INVALID, since either way it's not a bug in Camino code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

9 years ago
Created attachment 332227 [details]
Just to show the problem, I'm about to update the flash to see if that works.
(Reporter)

Comment 6

9 years ago
Just to finish this - I updated Flash, to no avail - however, I think I might have found the culprit (note: I'm not sure if this first step is necessary): I opened Camino, then opened a link inside Apple mail (specifically, it was to a facebook page) - and it started acting up. I restarted Camino, and forgot about the Facebook thing, until just a few minutes ago, when once again, I opened Camino, then a link inside Apple mail, and it's acting up again.
(Reporter)

Comment 7

9 years ago
(ignore above comments-  I couldn't reproduce it)

Updated

9 years ago
Duplicate of this bug: 450031
You need to log in before you can comment on or make changes to this bug.