Error Console (Left Bar, NOT Window) Doesn't Update Properly

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Robin Dean, Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

I'm working on my website and have the error console open to the left frequently for javascript testing. I load my site and see errors (good). I clear ALL of my private data (with my site and the error console still visible) and then click on my homepage button to revisit the page from scratch. This time, the error console remains blank (shows nothing). I repeat these steps (clear private data, go back to website) and again no errors are presented.

Reproducible: Always

Steps to Reproduce:
1. Open error console sidebar
2. Visit a webpage with errors
3. Leave both the error console and the page open while clearing ALL private data.
4. Return to the very same page and notice the blank error console.


Expected Results:  
The same errors should be presented if not already corrected by the designer.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
There is no Error Console sidebar in Firefox. Are you using the All-in-One Sidebar extension (or similar) or did you just create a sidebar bookmark to chrome://global/content/console.xul? If it's the former, then you'll have to report issues to the extension developers.
(Reporter)

Comment 2

10 years ago
I click on view -> sidebar -> error console. I didn't create a page for it. Perhaps I installed something a while back that is an add-on.

Either way, It doesn't behave as it used to (in v2). Do you see such an option from your view menu?

Comment 3

10 years ago
http://support.mozilla.com/en-US/kb/Menu+Reference#Sidebar

Nope, no option in the view menu.  There is no view -> sidebar -> error console by default.  Check what extensions you have installed.  When you figure out which it is, please post its name here for reference.  You'll need to contact them, because this issue only happens for you in the sidebar and not the actual window.
(Reporter)

Comment 4

10 years ago
How do I find my installed extensions?

Comment 5

10 years ago
(In reply to comment #4)
> How do I find my installed extensions?

tools -> add-ons -> extensions
(Reporter)

Comment 6

10 years ago
Alright,

I have Console(2) 0.3.9.1 and nothing else.

I'm ready to grab the other folk's attention.

How do I do that?

Comment 7

10 years ago
https://addons.mozilla.org/en-US/firefox/addon/1815
http://console2.mozdev.org/

Support for this add-on is provided by the developer at http://forums.mozillazine.org/viewtopic.php?t=577627

Closing as INVALID as this seems to be a bug in a non-Mozilla extension and not Firefox itself. (or, at least not an officially supported feature in Firefox) If it turns out to be caused by something that should be fixed on Mozilla's end, then they can re-open this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.