No tooltip by mouse over event in unifinder

VERIFIED FIXED in 0.9

Status

--
minor
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: andreas.treumann, Assigned: berend.cornelius09)

Tracking

({regression})

unspecified
regression
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
STEPS TO REPRODUCE:
===================

- Make unifinder visible
- move mouse over an event in the unifinder

RESULT:
=======

- nothing

EXPECTED RESULT:
================

- tooltip should be visible

REPRODUCIBLE:
=============

- always
Keywords: regression
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17pre) Gecko/2008081619 Calendar/0.9pre.

Did this used to work in Lightning before?

Comment 2

10 years ago
In Lightning's Unifinder, I see a tooltip for the Title if it doesn't fit in the column.  However, there isn't a tooltip that shows Title/Date/Location/Description/etc (like in the main view).  Which is wanted?  Maybe this is a feature request instead of a regression.
Created attachment 334237 [details] [diff] [review]
Fix - v1

This is a regression.

I moved the tooltips into our common sets to fix this bug. I could have consolidated that code a bit but I decided not to since we are shortly before a release and I don't want to risk more regressions. I have some bitrotted code in bug 366680 that consolidates the code, but that bug is a pain to fix on branch due to XUL peculiarities.

I also added some simple caching to the item tooltip code since I noticed some CPU load while hovering over items in the views.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #334237 - Flags: review?(Berend.Cornelius)
(Assignee)

Comment 4

10 years ago
Comment on attachment 334237 [details] [diff] [review]
Fix - v1

I regret I have to deny the patch because the tooltip is still not displayed on the tasktree in taskmode. After discussion with Pilipp I am taking over.
Attachment #334237 - Flags: review?(Berend.Cornelius) → review-
(Assignee)

Comment 5

10 years ago
Created attachment 334477 [details] [diff] [review]
patch v. #2

I resolved the remaining issue and did some consolidation.
Assignee: philipp → Berend.Cornelius
Attachment #334477 - Flags: review?(philipp)
Blocks: 449384
Comment on attachment 334477 [details] [diff] [review]
patch v. #2

r=philipp
Attachment #334477 - Flags: review?(philipp) → review+
(Assignee)

Comment 7

10 years ago
patch checked in on trunk and MOZILLA_1_8_BRANCH
->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
(Reporter)

Comment 8

10 years ago
Checked in lightning 2008081919 and sunbird 20080819 -> VERIFIED
Status: RESOLVED → VERIFIED

Comment 9

10 years ago
This caused Bug 451327
Depends on: 451327
You need to log in before you can comment on or make changes to this bug.