If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add link to "getting things into the tree" article on MDC when adding attachments

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: sheppy, Assigned: gerv)

Tracking

Details

(Whiteboard: bmo4.0-resolved)

(Reporter)

Description

9 years ago
It was suggested at the Summit that in order to help people understand the process of getting patches into the tree, it might be a good idea to have Bugzilla offer a link to the MDC article "Getting your patch into the tree" (http://developer.mozilla.org/en/docs/Getting_your_patch_in_the_tree) when a user is working on attaching a file to a bug.

Doing this will help inform people of the process, so that they will hopefully not necessarily expect immediate action, etc., and will know that the patch requires reviewing and so forth.
Um, we've been doing this since December already...

Look at https://bugzilla.mozilla.org/attachment.cgi?bugid=449036&action=enter and notice the "See the instructions on how to submit a patch." link.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393232
(Reporter)

Comment 2

9 years ago
The fact that a room full of people at the Summit all said we needed to add a link to that article during attachment submission means that it doesn't stand out enough.  We should add text to the effect of "For details on the patch submission and approval process, see..."
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → reed
Status: REOPENED → NEW
Assignee: reed → nobody
(Assignee)

Comment 3

7 years ago
The text on the bmo-4.0 branch is now:

<em>You can <a href="http://developer.mozilla.org/en/docs/Getting_your_patch_in_the_tree">read about the patch submission and approval process</a>.</em><br>

If you have other suggestions, let's hear them :-)

Gerv
Whiteboard: bmo4.0-resolved
Assignee: nobody → gerv
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → FIXED
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.