Hovering over links in large list is slow (with font-variant: small-caps;)

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Boldizsar Palotas, Assigned: roc)

Tracking

(4 keywords)

Trunk
perf, regression, testcase, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [depends on 430332], URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; hu; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; hu; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Hovering over links on the right-most column in http://bp.underground.hu/browse-list.html causes the link styles change to :hover very slowly.
Notice that the first two columns work properly. This might be because the links in the third column are:
    li {display:inline}
and/or styled the same (no different font size like in the 2nd col.)
It is reported (Hungarian: http://kispad.hu/torokgeek/200808/egy-firefox-teljesitmenybug-es-workaroundja.html?&) that bug exists an all platforms but need confirmation.
On Vista (Gecko/2008070208 Firefox/3.0.1) it also causes slightly higher CPU usage than hovering over links in the other columns.

Reproducible: Always

Steps to Reproduce:
1. Create a html page with lots of link in separate inline list items.
2. Hover over it.
Actual Results:  
Link hover styla update is slow.

Expected Results:  
No hover delay.

Comment 1

10 years ago
I can confirm this using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008080400 Mnenhy/0.7.5.20005 SeaMonkey/2.0a1pre

Also on Windows XP hovering Items in the right column eats more CPU than the middle or left one. The Page seems to be valid XHTML 1.0 Transitional, so it should work without Problems. 

It would be helpful, if someone can add an simplified Testcase.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: qawanted
Version: unspecified → Trunk

Comment 2

10 years ago
Confirmed on latest nightly. (2008080403)

Works: 2007062012 
Fails: 2007062013

Regression range:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2007-06-20+11%3A00&maxdate=2007-06-20+14%3A00
There are two possible culprits in that range; bug 385123 and bug 367177.
Blocks: 367177
Keywords: regression
Must say that the processor is already working heavily during loading.

Comment 5

10 years ago
This looks similar to bug 416673 (slow performance on zoom + hover, large
number of inline elements that flow into a narrow column).

Like in bug 416673, the column here has a CSS rule "font-variant: small-caps;". Removing this (e.g. via the DOM inspector) seems to bring performance back to normal. In fact, all three columns do have this CSS rule, although only the rightmost one is painfully slow. The middle column shows a bit of lag, but not much.
Keywords: perf
Created attachment 332479 [details]
testcase

Branch takes 687ms on the testcase, trunk takes 20518ms.

Why does changing a color of a link take so much cpu? Afaik, changing a color, shouldn't cause a reflow.

Updated

10 years ago
Component: Style System (CSS) → Layout
Flags: blocking1.9.1?
Keywords: testcase
QA Contact: style-system → layout
Whiteboard: qawanted

Updated

10 years ago
Blocks: 416673
(In reply to comment #6)
> Branch takes 687ms on the testcase, trunk takes 20518ms.

Which branch?

Comment 8

10 years ago
(In reply to comment #6)
> Created an attachment (id=332479) [details]
> testcase

OS X 10.5.4
Gecko 1.8.1 - Fx 2: 415ms
Gecko 1.9.0 - camino: 15491ms
Gecko 1.9.1 - minefield: 20301ms

Comment 9

10 years ago
Dup of bug 430332?  This bug uses "font-variant: small-caps;" and that bug uses "text-transform: uppercase;", but small-caps kinda implies uppercase...
Summary: Hovering over links in large list is slow → Hovering over links in large list is slow (with font-variant: small-caps;)
Yes, very likely the same issue.
Depends on: 430332
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P3
Assignee: nobody → roc
Whiteboard: [depends on 430332]
Fixed by checkin for bug 430332
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Flags: in-testsuite?
Bug 430332 is fixed on 1.9.1, therefore so is this.
Keywords: fixed1.9.1

Updated

9 years ago
Duplicate of this bug: 416673
verified FIXED on builds:

Trunk: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090528 Shiretoko/3.5pre ID:20090528045343


426ms


Shiretoko: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090526 Minefield/3.6a1pre ID:20090526044156

416ms
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
You need to log in before you can comment on or make changes to this bug.