Ctrl+L can move focus away from the add-bookmark panel without closing it

REOPENED
Unassigned

Status

()

Firefox
Keyboard Navigation
--
minor
REOPENED
10 years ago
8 years ago

People

(Reporter: Dmitriy, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I pressed Ctrl+D after pressed Ctrl+L but window with editing or adding bookmark don't hide, even if I pressed ESC button. I think this is not good. May be I wrong?

Reproducible: Always

Steps to Reproduce:
I pressed Ctrl+D after pressed Ctrl+L but window with editing or adding bookmark don't hide, even if I pressed ESC button. 
Actual Results:  
I think this is not good. 

Expected Results:  
May be I wrong?
(Reporter)

Updated

10 years ago
Severity: normal → trivial
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
Works for me - Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Pressed ctrl + L then ctrl + D and finally Esc. Add bookmark dialog was dismissed. Are these steps to reproduce correct?
Severity: trivial → normal
Version: 3.0 Branch → unspecified

Updated

10 years ago
Severity: normal → trivial
Version: unspecified → 3.0 Branch

Comment 2

10 years ago
I can reproduce this bug using Firefox trunk on Mac.

Steps to reproduce:
1. Press Cmd+D.
2. Press Cmd+L.

Result: The address bar is selected, but the add-bookmark panel remains on the screen.  Since the address bar now has focus, Esc no longer closes the add-bookmark panel.

Expected: Cmd+L in step 2 should be ignored.
Severity: trivial → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: This keyboard sequence work screwy → Ctrl+L can move focus away from the add-bookmark panel without closing it
Version: 3.0 Branch → Trunk

Comment 3

10 years ago
I can reproduce using the ctrl + D -> ctrl + L steps. Read the reporter's comment too literally. So my comment 1 is not relevant.

Comment 4

10 years ago
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/2008080403 Minefield/3.1a2pre
(Reporter)

Comment 5

10 years ago
(In reply to comment #1)
> Works for me - Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1)
> Gecko/2008070208 Firefox/3.0.1
> 
> Pressed ctrl + L then ctrl + D and finally Esc. Add bookmark dialog was
> dismissed. Are these steps to reproduce correct?
> 

Yes, this correct. Thank you!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

10 years ago
But if sequece is 
1) Ctrl+D
2) Ctrl+L
3)Esc

Window stay on screen
Resolution: FIXED → WONTFIX

Comment 7

10 years ago
Yeah, that's a bug that should be fixed :)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

10 years ago
Flags: wanted-firefox3.1?

Updated

9 years ago
Flags: wanted-firefox3.5? → wanted-firefox3.6?

Updated

8 years ago
Flags: wanted-firefox3.6?
You need to log in before you can comment on or make changes to this bug.