continuous (streaming) pages do not update properly

RESOLVED WORKSFORME

Status

()

Core
Networking
P3
minor
RESOLVED WORKSFORME
18 years ago
15 years ago

People

(Reporter: Stephan Götter, Assigned: Darin Fisher)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I get only the first page and old messages.
The refresh doesn't work :(

Thanks for fixing it

Comment 1

18 years ago
reporter: provide a URL where this is happening please.
(Reporter)

Comment 2

18 years ago
Sorry, know only german chats.
Just enter nick and passwords.

http://www.chat-dome.de/chat/flirt/
or
http://chat.de/PCH/PCHC/pchc.htm

Comment 3

18 years ago
Linux, build ID 2000070908
Windows 95, build ID 2000070908

I suspect this is XP.

What seems to happen is that the connection is never closed, and content is 
appended as people speak. Netscape 4.73 and IE5.01 render these immediately, but 
Mozilla only renders new content for a couple of seconds, and then waits for the 
connection to close before rendering the rest.

A site where you can see this happen without needing to have an account (though 
you can freely create them at those chat sites if you want to test those) is 
http://grc.com/. You'll need PSM installed though. Click the "Shields UP!" on 
that page, then click the "Probe My Ports!" button on the next page. In 
Netscape and IE, as each new port probed is added, it is rendered. In Moz, it 
renders a few, then stops updating the page till it's all done.

Is this layout?

Confirming this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
Behavior repeated on Win32 070908 Nightly. Marking as XP.
OS: Linux → All
Hardware: PC → All

Comment 5

18 years ago
updating summary,
Could be netlib buffering the data or layout not reflowing often enough, can
someone figure out the proper component please.

hitting stop will force the content to show. but it also closes the stream,
which stops it from receiving further updates to the page.
Component: Browser-General → Networking
Keywords: helpwanted
Summary: Javascript/Refresh based Chats don't work with Mozilla :( → continuous (streaming) pages do not update properly

Comment 6

18 years ago
setting new default owner.
Assignee: asa → gagan
QA Contact: doronr → tever

Comment 7

18 years ago
*** Bug 43491 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
argh... this could mean trouble for our 8K read-chunks. 

Comment 9

18 years ago
Yes. I was going to make them auto-adjustable. I've a bug for M18 or so about 
it. Though it's not criticial for nsbeta2

Comment 10

18 years ago
->future
Assignee: gagan → ruslan
Target Milestone: --- → Future

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 11

17 years ago
pulling in ruslan's necko bugs ->darin
Assignee: ruslan → gagan
Status: ASSIGNED → NEW
Target Milestone: Future → M19

Comment 12

17 years ago
->darin
Assignee: gagan → darin
Target Milestone: --- → Future
(Assignee)

Comment 13

17 years ago
this shouldn't be a problem anymore since we dispatch packets (via
onDataAvailable) as they are read off the socket.  this could be
more of an issue with layout if content is not being rendered frequently
enough.
Severity: normal → minor
(Assignee)

Comment 14

17 years ago
i don't believe this is a problem anymore.. marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 15

16 years ago
reporter:

This bug is a "futured" or "untargeted" bug which has been "resolved/works for
me". Most bugs meeting this criteria are usually somewhat out of date or working
in the current builds.

If this bug is not happening for you in a recent build (such as the Mozilla
daily build, Mozilla 0.9.3, or Netscape 6.1), please use the friendly "Mark bugs
as VERIFIED" radio button to set this bug to "VERIFIED/WORKS FOR ME"
If you reported the bug on a platform (e.g. Linux) and other contributors
reported on another platform (e.g. Mac OS), please comment that it works for you
 but do not verify it yet.

For these multi-platform bug reports, we need to verify all reported platforms
-OR- create new "still broken on platform X" bugs when you verify.

Updated

15 years ago
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.