Error console reports version.length is not a function

RESOLVED DUPLICATE of bug 449127

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 449127
10 years ago
10 years ago

People

(Reporter: Bart McGlothin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When trying to load Cisco meeting place session using Firefox 3 I receive this error in the error console "version.length is not a function".  The below code is the complete function that causes the error.  IE7 and Firefox 2.0.0.16 do not have a problem. using the browser test feature of the site, all tests pass fine.  it only shows this problem when actually trying to attend a meeting.  I am using Vista 32 bit with SP1.  This problem also exists using Firefox3.0.1 on Windows 2003 server.


function chkJavaVer(version)
{
	var strLength = 0;
	
	if (navigator.family == 'ie4')
		strLength = version.length;
	else
		strLength = version.length();

	if ( strLength > 3 )
		version = version.substring(0, 3);
	
	for ( var i = 0; i < badVersions.length; i++ )
	{
		if ( version == badVersions[i] )
		{
			return false;
		}
	}

	return true;
}


Reproducible: Always

Steps to Reproduce:
1.open URL in browser  http://meetingplace.cisco.com
2.type in meeting ID number (must have valid number), click attend meeting
3.enter attendee name, click attend meeting.
4.taken to meeting info window.  New window opens and hangs with the Java error.  Window shows "checking your browser settings".  
Actual Results:  
new window just hangs showing "checking your browser settings".
Open error console, last entry states "version.length is not a function".
Error: version.length is not a function
Source File: http://sjc12-c1-alt-mp.cisco.com/mpweb/jslib/wcLaunchWebConference_tpl.js
Line: 240

Expected Results:  
Window should go through loading java application next then take you to the meeting shared presentation window.

This is a well known Javascript function and should not cause an error.  Older version of Firefox works fine.
Many companies use Cisco meeting place and there is a large firefox userbase.

Comment 1

10 years ago
Accidentally submitted twice
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449127
You need to log in before you can comment on or make changes to this bug.