Status

Webtools Graveyard
Verbatim
RESOLVED DUPLICATE of bug 449132
10 years ago
2 years ago

People

(Reporter: dschafer, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
Currently, rights are stored in a flat file; we should move them to a database.  Rights are done on a language / project / user basis, so this move should not be too tricky; a boolean column for each right seems like the most logical approach.

Note that attachment 330595 [details] [diff] [review] introduced some odd behavior in function
getuserswithrights in projects.py to work around the standard "dots in .prefs
file" issue, and that this code should be removed when this bug is fixed.

This was split from bug 446441
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449132
(Assignee)

Updated

2 years ago
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.