bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

3pane Accelerators: Search menu should match spec

VERIFIED DUPLICATE of bug 44873

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 44873
18 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: timeless)

Tracking

({helpwanted})

Trunk
mozilla0.9.2
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview: In the 3pane window the accelerators for the Search menu should match 
the spec.
(Reporter)

Updated

18 years ago
Keywords: nsbeta3, ui
QA Contact: lchiang → nbaca

Updated

18 years ago
Target Milestone: --- → M18
(Assignee)

Comment 1

18 years ago
past half way
Assignee: putterman → timeless
OS: Windows NT → All
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

18 years ago
*** Bug 44926 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Keywords: nsbeta3
Target Milestone: M18 → Future

Comment 3

18 years ago
per mail triage:  remove nsbeta3 nomination and move to future milestone.  For 
the short term, we will combine items here into three bugs (in 3pane) to address 
for nsbetat3:  1. delete, change text, move menuitems;  2. enable/disable and 
text changes on context (dynamic);  3.  accelerator keys to work (ie. what is 
shown in the menus actually does something)

When this bug gets revisited after the first release, we'll need to see what 
items remaining that need to be addressed.

Comment 4

18 years ago
my mistake.  Correcting milestone back to previous one set.  Netscape6 doesn't 
need this by nsbeta3 so leaving the nsbeta3 nomination off.  This can be fixed 
at any time designated by timeless for Mozilla.
Target Milestone: Future → M18
(Assignee)

Updated

18 years ago
Keywords: helpwanted, mozilla0.9
Target Milestone: M18 → mozilla0.9

Updated

18 years ago
Blocks: 70185
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9 → mozilla0.9.2

Comment 5

17 years ago
The search menu has changed somewhat. The global stuff is going/gone, whilst the
mailnews bits seem to work fine accelerator-wise. Anyone know of a good reason
why this bug should be left open?
(Assignee)

Comment 6

17 years ago
yeah to follow mpt's suggestion's from bug 67414 which i'll quote:
For mail/news:
5.  Change `Find in This Message ...' to `Find ...' and move it to the `Edit'
    menu, immediately following the separator under `Select >'.
6.  Move `Find Again' to the `Edit' menu, immediately following `Find ...'.
7.  Change `Search Mail/News Messages' to `Search Messages ...' and move it to
    the `Edit' menu, immediately following `Find Again' (or following `Find
    Previous', if bug 77704 is implemented first).
8.  For bonus points, give `Search Messages ...' the keyboard shortcut
    Shift+accel+F, as in 4.x.
9.  Remove the `Search the Web' item from the `Search' menu. (It's an *e-mail*
    program!)
10. Remove the `Search' menu.

I'm going to wait a day for preapproval from jglick before i try to make this 
patch.
Blake Ross:
blake@netscape.com
blake@qazilla.org
BlakeR1234@aol.com
blaker@netscape.com
blaker@telocity.com
um... right.
(Assignee)

Comment 7

17 years ago
Created attachment 38365 [details] [diff] [review]
per mpt's suggestions.

Comment 8

17 years ago
With Timeless's permission, dupping against the more general and up-to-date bug.

*** This bug has been marked as a duplicate of 67414 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

17 years ago
.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

17 years ago
arg. while i gave mpt permission i failed to give him proper instruction.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 11

17 years ago

*** This bug has been marked as a duplicate of 44873 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 12

17 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.