If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

DHTML: form removed using removeChild() is still accessible

RESOLVED DUPLICATE of bug 307415

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 307415
9 years ago
9 years ago

People

(Reporter: Matt Fozard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

A form removed from an HTML document using document.body.removeChild() is still accessible using document.formname. It is (correctly) no longer available using document.forms['formname'].

Reproducible: Always

Steps to Reproduce:
See attached script to reproduce
Actual Results:  
Script result:

document.forms["myForm"] should be undefined and is undefined.
document.myForm should be undefined and is [object HTMLFormElement].

Expected Results:  
document.forms["myForm"] should be undefined and is undefined.
document.myForm should be undefined and is undefined.

See attached script
(Reporter)

Comment 1

9 years ago
Created attachment 332356 [details]
Script to reproduce the bug

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307415
You need to log in before you can comment on or make changes to this bug.