Closed Bug 449416 Opened 11 years ago Closed 7 years ago

Add setup/account setting check-box.button for Exchange server to set user_pref(mail.server.serverXX.fetch_by_chunks, false);

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: aw_kohr, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a2pre) Gecko/2008073100 Shredder/3.0b1pre

Please Add in the account setup wizard dialog boxes and the account specific "Server Settings" settings a check-box or radio button to select Exchange server (with imap enabled) to set for the specific incoming mail server user_pref(mail.server.serverXX.fetch_by_chunks, false); (where XX is the number of the existing or to be created account)


Reproducible: Always

Steps to Reproduce:
1. Go to Tools -> Acccount settings.
2.Go to The specific acocunt -> Server Settings.
or. 
1. Quit Thunderbird/shredder
2. rename you thunderbird profile.
3. In new account setup . Select email account
4. Enter in Identity
5. Server information Select server type.
Actual Results:  
No settings check-box to deal with exchange server.

Expected Results:  
There to be a checkbox radio button that would say exchange server (over imap) or something like that, that would then set settings such that thunderbird played nicely with Microsoft exchange servers bad imap implementation. and worked in solutions such as the one above. 

This would be in an attempt to allow new users to set settings that would keep them from experiencing bugs like 
92111 https://bugzilla.mozilla.org/show_bug.cgi?id=92111
and possibly but possibly not
https://bugzilla.mozilla.org/show_bug.cgi?id=384479

There may be other settings that it may be ideal for this checkbox to set as well.

Apple's mail under 10.4 while using still using imap for exchange servers had a setup drop down choice for exchange servers.

Entourage X & 2004 ( microsoft products) Also have a exchange specific setting for when you are communicating over imap to an exchange server. (although entourage does implement a lot more for exchange than apple or you would have to)
this might also be usefull for solving bug #390795 but then again may not be as per it's notes.
changed to all because according to 92111 it happens on other platforms as well.
OS: Mac OS X → All
xref bug 92111 and bug 390795 for ease of search and tracking.
Bug 92111 is fixed, so this feature is no longer required.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
QA Contact: preferences
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.