Closed Bug 449446 Opened 12 years ago Closed 11 years ago

Add redirects for key pages moved during archiving process

Categories

(www.mozilla.org :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 453475

People

(Reporter: davidwboswell, Unassigned)

References

Details

Attachments

(2 files)

We can use this bug to track setting up redirects for any pages moved during archives that should be automatically redirected instead of sending people to the 404 page that provides a link to the archive.

Here is the first batch of redirects I've set up.  Feel free to suggest others.

Redirect permanent /quality/qfa.html http://developer.mozilla.org/en/docs/Crash_reporting
Redirect permanent /quality/bug-writing-guidelines.html http://developer.mozilla.org/en/docs/Bug_writing_guidelines
Redirect permanent /quality/help/ http://quality.mozilla.org/get-involved
Redirect permanent /newlayout/bugathon.html http://developer.mozilla.org/en/docs/Reducing_testcases
I edited the existing redirect for the /quality/help main page and added a few more redirects for other content in that directory.
Attachment #333240 - Attachment is patch: true
Attachment #333240 - Attachment mime type: application/octet-stream → text/plain
Adding another redirect to migrated unconfirmed bugs docs and also removed anchor link from an existing redirect.
Currently, the first google hit for "XUL reference" points to

http://www.mozilla.org/xpfe/xulref

which is a 404.  
I've added a redirect for http://www.mozilla.org/xpfe/xulref

BTW, the Google index seems to have updated as well.  I'm seeing the first result point to MDC.
Can we please redirect:
http://www.mozilla.org/quality to http://quality.mozilla.org
http://www.mozilla.org/quality/help to http://quality.mozilla.org/get-involved

? David said in email he'd done these two, but they don't seem to be working (I get 404s). I'm hoping to revive the BugAThon soon, so there will be more redirects to do.

Gerv
Re comment #5, there are some configuration problems with redirects that are preventing us from correctly dealing with the /quality and /quality/help links.  See bug 450490 for more information.  Any help figuring out what's going on here is appreciated.
I'm marking this as a dupe since we're tracking the set up of automatic redirects for archived pages in bug 453475.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453475
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.