ARIA role: alert will fail if the text content is more than a certain length

RESOLVED INVALID

Status

()

Firefox
Disability Access
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: clc4tts, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

ARIA role: alert does not always cause the added node to be spoken by the user's assistive technology.

Under JAWS 9, if the text content of an alert is greater than a certain length, the alert will not be spoken when it is added.

Please see the attached example.

Reproducible: Always

Steps to Reproduce:
1. Open the attached example while running Firefox 3 and JAWS 9.
2. Click on "Show the alert that works". Notice that the alert text is read out.
3. Click on "Show the alert that fails". Notice that the alert text is not read out.
Actual Results:  
The alert is only read in the first case, but nothing is spoken for the second case.

Expected Results:  
Both alerts should be spoken.
(Reporter)

Comment 1

10 years ago
Created attachment 332623 [details]
Demonstrates the problem with ARIA alert role

Comment 2

10 years ago
This is clearly a JAWS bug. The test works fine with NVDA, both alerts are spoken there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 3

10 years ago
Did this bug get reported to Freedom Scientific?

Comment 4

10 years ago
(In reply to comment #3)
> Did this bug get reported to Freedom Scientific?

I did, but since I had some e-mail problems at the time and didn't get a reply back, I just resent it.
You need to log in before you can comment on or make changes to this bug.