TM: access-fannkuch.js in the browser iloops

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: brendan, Unassigned)

Tracking

Trunk
mozilla1.9.1
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
dvander and I saw this, I poked around. The perm array had slow ops, yet fslots[4] and fslots[5] were undefined, but the 8 int slots that should've started at dslots[0] were shifted to start at dslots[1]. This left dslots[0] undefined (note: not JSVAL_HOLE), which converts to NaN, so

         while (!((k = perm[0]) == 0)) {

in function fannkuch is never gonna terminate.

We've never seen this in a shell run.

/be
We've seen something similar, though, which led to the fannkuch subset that we excerpted into trace-test.js.  Now if I could only remember what it was exactly...
valgrind doesn't show anything interesting.  Does the non-debug iloop or does it crash, because Schrep mentioned a crash at the end of his Sunspider run.  I was trying to reproduce that and I'm pretty sure I was nearing the end of the test.
Can't reproduce as of tip.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 4

10 years ago
no patch->wfm
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.