All users were logged out of Bugzilla on October 13th, 2018

UTF-8 message is displayed wrong in "new mail" popup

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
10 years ago
13 days ago

People

(Reporter: a0506717, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2018-10-15])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Version 2.0.0.16 (20080708)

When Thunderbird receives an E-Mail with the following charset and encoding:
Subject: Neuer =?UTF-8?B?R8Okc3RlYnVjaGVpbnRyYWc=?=
Mime-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: BASE64

the popup which is displayed in top of the system tray when a new e-mail is received shows the encoded UTF-8 message string instead of the human readable message! In the main window of thunderbird the message is shown correctly!

Notice: The popup shows the subject line (which is also in UTF-8) correctly in the "decoded" way!

Reproducible: Always

Steps to Reproduce:
1. Use the following PHP script to reproduce the error:
<?php
	$to="mail@mail.com";
	$subject="Neuer Gästebucheintrag";
	$message="Neuer Eintrag im Gästebuch!";
	
	// UTF-8 für E-Mail
        mb_language("uni");
        mb_send_mail($to, $subject, $message);
?>
Actual Results:  
When Thunderbird receives the new mail, the "new mail" popup displays the UTF-8 message string.

Expected Results:  
The "new mail" popup should display the message in a human readable way.
Hi Johannes,

Do you still experience this issue with more recent versions of Thunderbird ?
Could you save one of these emails and attach them to this bug ?
(Reporter)

Comment 2

10 years ago
Hi!

Yes, the problem still exists in Thunderbird 2.0.0.21!
E-Mail source:

Return-Path: <b884138307@prokids.at>
Received: from lmtpproxyd (joan.univie.ac.at [131.130.3.110])
	 by lillian.univie.ac.at (Cyrus v2.3.13-univie-1.2) with LMTPA;
	 Fri, 03 Apr 2009 07:38:12 +0200
X-Sieve: CMU Sieve 2.3
Received: from ruth.univie.ac.at (ruth.univie.ac.at [131.130.3.101])
	 by joan.univie.ac.at (Cyrus v2.3.13-univie-1.1) with LMTPA;
	 Fri, 03 Apr 2009 07:38:12 +0200
Received: from smarthost01.bon.at ([213.33.76.20] helo=smarthost01.bon.at)
	by ruth.univie.ac.at with esmtp (Exim 4.69)
	(envelope-from <b884138307@prokids.at>)
	id 1Lpc6W-0001Nq-C8
	for a0506717@unet.univie.ac.at; Fri, 03 Apr 2009 07:38:12 +0200
Received: from msplhs09.bon.at (unknown [195.3.105.58])
	by smarthost01.bon.at (Postfix) with ESMTP id 5536235A6CF
	for <a0506717@unet.univie.ac.at>; Fri,  3 Apr 2009 07:38:10 +0200 (CEST)
Received: from prokids.at (localhost.localdomain [127.0.0.1])
	by msplhs09.bon.at (8.13.1/8.13.1) with ESMTP id n335c9Qv003793
	for <a0506717@unet.univie.ac.at>; Fri, 3 Apr 2009 07:38:09 +0200
Received: (from b884138307@localhost)
	by prokids.at (8.13.1/8.13.1/Submit) id n335c92T031784;
	Fri, 3 Apr 2009 07:38:09 +0200
Received-SPF: none (ruth.univie.ac.at: domain of b884138307@prokids.at
	does not designate permitted sender hosts)
Date: Fri, 3 Apr 2009 07:38:09 +0200
Message-Id: <200904030538.n335c92T031784@prokids.at>
To: a0506717@unet.univie.ac.at
Subject: Neuer =?UTF-8?B?R8Okc3RlYnVjaGVpbnRyYWc=?=
From: a0506717@unet.univie.ac.at
Mime-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: BASE64
X-DCC-Univie-Metrics: ruth.univie.ac.at 32723; Body=1 Fuz1=1 Fuz2=1
X-Univie-Virus-Scan: scanned by ClamAV on ruth.univie.ac.at
X-Univie-DKIM-Check: header.i=@unet.univie.ac.at result:unsigned
X-Univie-Spam-Score: 0.0
X-Univie-Spam-Score-Int: 0
X-Univie-Spam-Level: /
X-Univie-Spam-Checker-Version: SpamAssassin 3.2.5 (2008-06-10) on
	ruth.univie.ac.at
X-Univie-Spam-Status: No, score=0.0, tests=none
X-Univie-Spam-Languages: 
X-Univie-Spam-Relay-Countries: AT AT **
X-Univie-Spam-Report: Content analysis details:   (0.0 points) 

SGFsbG8gQWRtaW4sCgpFaW4gQmVudXR6ZXIgaGF0IGVpbmUgbmV1ZSBOYWNocmljaHQgaW4gZGFz
IEfDpHN0ZWJ1Y2ggdm9uIGh0dHA6Ly93d3cucHJva2lkcy5hdC9jbXMgZ2VzY2hyaWViZW46Cg0K
DQpOYW1lOiB0ZXN0DQpOYWNocmljaHQ6IGRhcyBpc3QgZWluZSB0ZXN0bmFjaHJpY2h0ISEhDQoN
CkzDtnNjaGVuOgpodHRwOi8vd3d3LnByb2tpZHMuYXQvY21zL2luZGV4LnBocD9vcHRpb249Y29t
X2Vhc3lib29rJkl0ZW1pZD0xNiZmdW5jPWRlbGV0ZWVudHJ5JmdiaWQ9MjQmbWQ9ZTg2ZWY5ODZk
YzViNjhjOWI3ZTRlN2VjZGI5M2E5NDYKS29tbWVudGllcmVuOgpodHRwOi8vd3d3LnByb2tpZHMu
YXQvY21zL2luZGV4LnBocD9vcHRpb249Y29tX2Vhc3lib29rJkl0ZW1pZD0xNiZmdW5jPWNvbW1l
bnQmZ2JpZD0yNCZtZD1lODZlZjk4NmRjNWI2OGM5YjdlNGU3ZWNkYjkzYTk0NgogQmVhcmJlaXRl
bjoKaHR0cDovL3d3dy5wcm9raWRzLmF0L2Ntcy9pbmRleC5waHA/b3B0aW9uPWNvbV9lYXN5Ym9v
ayZJdGVtaWQ9MTYmZnVuYz1lZGl0JmdiaWQ9MjQmbWQ9ZTg2ZWY5ODZkYzViNjhjOWI3ZTRlN2Vj
ZGI5M2E5NDYKIEVpbnRyYWcgdmVyw7ZmZmVudGxpY2hlbi9PZmZsaW5lIG5laG1lbjoKaHR0cDov
L3d3dy5wcm9raWRzLmF0L2Ntcy9pbmRleC5waHA/b3B0aW9uPWNvbV9lYXN5Ym9vayZJdGVtaWQ9
MTYmZnVuYz1wdWJsaXNoJmdiaWQ9MjQmbWQ9ZTg2ZWY5ODZkYzViNjhjOWI3ZTRlN2VjZGI5M2E5
NDYKCgogQml0dGUgYW50d29ydGVuIFNpZSBuaWNodCBhdWYgZGllc2UgTmFjaHJpY2h0LCBkYSBz
aWUgYXV0b21hdGlzY2ggZ2VuZXJpZXJ0IHd1cmRlIHVuZCBsZWRpZ2xpY2ggaW5mb3JtYXRpdmVu
IFp3ZWNrZW4gZGllbnQuCg==
AFAIR, there are not-so-small-number of reports for new mail alert of base 64 encoded mail.
  Content-Transfer-Encoding:BASE64 for:
  (a) mail payload=mail body (non-multipart mail)
  (b) first part of multipart/mixed mail
      - first part is correct mail body : This bug, Bug 418309 
      - first part is attachment part(i.e. no mail body part) : Bug 449756
  (c) multipart/related or multipart/alternative mail or part in multipart mail
Case (a) may be already resolved by improvment in other bug.
Bug 418309 is already DUP'ed to Bug 449756, because Bug 449756 is very clear report like this bug.
Reporter what you think about comment #? This issue is a dupe?
(In reply to comment #4)
> Reporter what you think about comment #? This issue is a dupe?
is comment #3
(Reporter)

Comment 6

9 years ago
Bug 449757 seems to be very similar to my report, but however mine was reported earlier so the other bug is a dupe ;-)

Updated

9 years ago
Duplicate of this bug: 449756
It happens also to me yesterday (but I can't reproduce with message in comment #2 and I can't provide an email testcase for now).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091028 Lightning/1.0pre Shredder/3.0pre ID:20091028031844
Component: General → Mail Window Front End
QA Contact: general → front-end

Comment 9

8 years ago
Created attachment 489454 [details]
Tooltip for new email

Comment 10

8 years ago
Comment on attachment 489454 [details]
Tooltip for new email

Skip this, we found the problem with the entities.

Comment 11

7 years ago
Aureliano do you still see this?

Comment 12

13 days ago
Johannes, do you still see this issue?
Flags: needinfo?(a0506717)
Whiteboard: [closeme 2018-10-15]
You need to log in before you can comment on or make changes to this bug.