google calendar infinite loop

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Tom Schneider, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: parity-Safari, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.16) Gecko/20080703 SeaMonkey/1.1.11
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.16) Gecko/20080703 SeaMonkey/1.1.11

Going to my bookmarked calendar for google, tab goes between 'Loading ...' and 'Google Calendar' (or something like those) - switching back and forth rapidly.  The page stays blank, it's an infinite loop.  Going to google
sign in, enter email and password, signed in.  Use the more to navigate to the Calendar.  The calendar is there and fine.  sign out and ... infinite loop as above with page being:

https://www.google.com/accounts/ServiceLogin?service=cl&passive=true&nui=1&continue=http%3A%2F%2Fwww.google.com%2Fcalendar%2Frender&followup=http%3A%2F%2Fwww.google.com%2Fcalendar%2Frender&ltmpl=suggest

unix diff shows that this is the same address as the initial url I gave.  going straight to this url gives an infinite loop.

going to this url on Safari version 3.1.2 (5525.20.1) [the latest version] brings me to the google calendar sign in page.  signing in in Safari gives the google calendar.  The problem does not occur in safari.  Signing out of safari works fine.



Reproducible: Always

Steps to Reproduce:
1. try to sign into google calendar from bookmark
OR
2. after navigating to the calendar, sign out.

Actual Results:  
infinite displayed loop

Expected Results:  
I expect to see the calendar or to log out of the calendar.

This just started happening.  I reported
https://bugzilla.mozilla.org/show_bug.cgi?id=448754
bug 448754 and observed this first after resetting my parameters as indicated in that bug.  I removed the parameter but this still happens so I THINK they are unrelated, but they came so close together that maybe there is some relationship.

Comment 1

10 years ago
Can not confirm without login.
Whiteboard: parity-Safari
Version: unspecified → SeaMonkey 1.1 Branch

Comment 2

10 years ago
Same issue as (or at least related to) bug 430021 on Gmail looping?
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Same issue as (or at least related to) bug 430021 on Gmail looping?

Yes looks similar.


(Reporter)

Comment 4

10 years ago
(In reply to comment #2)
> Same issue as (or at least related to) bug 430021 on Gmail looping?

It's not the same.  When I go to Gmail, I don't get the loop.  But going to the calendar gives me the looping.

I went to google.  Select 'More' then Calendar.  It's looping saying "Loading..."
and "Google Calendar" alternating rapidly on a blank page.  The address is:

https://www.google.com/accounts/ServiceLogin?service=cl&passive=true&nui=1&continue=http%3A%2F%2Fwww.google.com%2Fcalendar%2Frender&followup=http%3A%2F%2Fwww.google.com%2Fcalendar%2Frender&ltmpl=suggest

I am not logged in.  Giving this address to Safari gives sign in page.  So I'm getting the same results as reported above.

Comment 5

10 years ago
(In reply to comment #4)
> It's not the same.  When I go to Gmail, I don't get the loop.  But going to the
> calendar gives me the looping.

While it's certainly not identical in all cases, the underlying issue may be the same. It appears to be a combination of caching, cookies, and redirection between different pages. If you look at the comments in the Gmail bug, you will notice that it occurs in some configurations but not in others, thus you may see it in calendar but not in mail.

> I went to google.  Select 'More' then Calendar.  It's looping saying
> "Loading..." and "Google Calendar" alternating rapidly on a blank page.

This is exactly the behavior which was reported for Gmail access, so this would support that assumption. New is that you also see the looping when logging out, according to your initial report.

Comment 6

10 years ago
Helps it remove Cookie (Tools-Cookie Manager) and restart SeaMonkey?
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> Helps it remove Cookie (Tools-Cookie Manager) and restart SeaMonkey?

I went to the cookie manager and removed all cookies that start with 'google'.
The infinite loop on starting the calendar is gone!!!!

Of course I no longer have the cookies ...
If you can tell me where they are stored, I might be able to recover them from my TimeMachine backups - if you want them.

Great suggestion!!

Comment 8

10 years ago
Since there are no further comments from the reporter, resolving WFM then.
Please feel free to reopen if the problem reoccurs. For your 2nd remark, if you deleted the cookies, they are physically gone, thus couldn't be used for any analysis. This appears to be to a good portion a Google problem as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
That's fine, I haven't had any problem since then, so the issue is resolved.
THANKS!!
You need to log in before you can comment on or make changes to this bug.