If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Creating saved search across IMAP folder containing pipe character crashes Thunderbird.

RESOLVED DUPLICATE of bug 383423

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 383423
9 years ago
7 years ago

People

(Reporter: Nick Grimshaw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en; rv:1.8.1.16) Gecko/20080805 Epiphany/2.22 Firefox/2.0.0.16
Build Identifier: version 2.0.0.16 (20080805)

Creating a saved search and including in the search a folder with a name containing a pipe-character crashes Thunderbird when attempting to save the search.

Reproducible: Always

Steps to Reproduce:
1. Have an IMAP account.
2. Create a folder within that account with a pipe-character in the name e.g. "pipe|folder".
2. Create a new saved search, name it "test", leave the default search-criteria.
3. Select the 'Choose' button to pop-up the 'Select Folder(s)' window, select only "pipe|folder", click 'OK'.
4. Click 'OK' on the 'New Saved Search Folder' window.
Actual Results:  
Thunderbird crashes. The search has not been saved when Thunderbird is restarted.

Expected Results:  
Thunderbird should save the saved-search and call it "test"; selecting the folder should carry out the search according to the selected criteria.
(Reporter)

Comment 1

9 years ago
This bug is very-probably related to bug 449687 (which was the one I discovered initially, and is slightly more serious).
DUP of Bug 383423, isn't it? (See dependency tree for meta bug 124287)

Comment 3

9 years ago
Yes, this looks like it's the same problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383423
You need to log in before you can comment on or make changes to this bug.