Build failure on systems that don't have XFree86 includes

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
10 years ago
7 years ago

People

(Reporter: Dimitrios Apostolou, Unassigned)

Tracking

3.0 Branch
SGI
IRIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: Firefox/3.0.1

On SGI Irix, where the X server is not derived from XFree86. the following patch is needed for the file widget/src/gtk2/nsWindow.cpp to compile correctly. 

I wonder how other non-XFree86 platforms handle that.

Reproducible: Always
(Reporter)

Updated

10 years ago
OS: Other → IRIX
Hardware: Other → SGI
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

10 years ago
Created attachment 332869 [details] [diff] [review]
because SGI Irix doesn't have XFree86 Includes
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 3

7 years ago
After two years of not getting *any* reply, I now get a warning about closing this... This is not a bug report, but a PATCH so if you don't apply it it won't get fixed.
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.