round() doesn't exist on some systems, use NS_round() instead

RESOLVED DUPLICATE of bug 449718

Status

()

RESOLVED DUPLICATE of bug 449718
11 years ago
11 years ago

People

(Reporter: jimis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: Firefox/3.0.1

round() is a C99 function and doesn't exist on all systems like SGI Irix (it provides rint() for rounding). Apply the following patch to allow gfx/src/thebes/nsThebesDeviceContext.cpp, the only file calling round(), to compile cleanly. 

Reproducible: Always
(Reporter)

Comment 1

11 years ago
bugzilla timed out while submitting the bug, so I submitted it twice
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449718
You need to log in before you can comment on or make changes to this bug.