White "Other Firefox Support" highlighted link is hard to read against the background

VERIFIED FIXED in 0.6.3

Status

support.mozilla.org
General
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: stephend, Assigned: lorchard)

Tracking

({regression})

unspecified
0.6.3
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only theme, URL)

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
Created attachment 332902 [details]
Screenshot

This was mentioned over in https://bugzilla.mozilla.org/show_bug.cgi?id=442182#c26, and is a regression from that bug.

Steps to Reproduce:

1. Load http://support-stage.mozilla.org/en-US/kb/Other+Firefox+support
2. Look at the white "Other Firefox Support" link against the background

See screenshot.

Comment 1

10 years ago
FWIW, in order to disable commments on that article, I've switched it to mozad.css.

Comment 2

10 years ago
As per Comment #1, it'll be fine on production.  However, this doesn't seem to go well with the "How to Contribute" category that the main title has.  Regardless, it's ok for now, downgrading to normal and assigning to Laura since I imagine I'll be gone before we come up with a good solution (I'm sure djst will think of something).

Easiest thing to do is to shift the header down 15 pixels so that the blue is lower.  Not the best solution, but the easiest.
Assignee: bkrausz → laura
Severity: major → normal

Comment 3

10 years ago
Created attachment 332971 [details]
when logged out

The same problem still appears when logged out. See screenshot.

Comment 4

10 years ago
Created attachment 332972 [details]
when logged in
(Reporter)

Updated

10 years ago
Target Milestone: --- → 0.6.2

Comment 5

10 years ago
Not sure I understand why this is on a different template than the other pages - the gray header image also looks kind of funny on the blue.
Target Milestone: 0.6.2 → 0.6.3

Updated

10 years ago
Assignee: laura → lorchard
(Assignee)

Comment 6

10 years ago
Created attachment 335535 [details] [diff] [review]
Tweaks to recolor links and move background on "mini" style variant

It looks like some pages have a "mini" style variant, where the search bar is hidden and there's no large title at the top - not sure why it's this way.  Also, I wasn't able to reproduce Chris Ilias' screenshot differences between logged in and logged out.

As a quick fix, I tweaked the CSS in this patch to give the sidebar links a blue color like other links on the page when the "mini" variant is in effect.  Additionally, I pushed the background up a bit in order to make the grey section rule look better.
Attachment #335535 - Flags: review?(laura)

Comment 7

10 years ago
Comment on attachment 335535 [details] [diff] [review]
Tweaks to recolor links and move background on "mini" style variant

WFM
Attachment #335535 - Flags: review?(laura) → review+
(Reporter)

Comment 8

10 years ago
Have people been changing templates?  http://support.mozilla.com/en-US/kb/Other+Firefox+support and staging are both fine, seemingly without this fix...
(Assignee)

Comment 9

10 years ago
Hmm.. might need to look into that a little more - seems confusing, since that page is "Other Firefox support" but the big title says "How to Contribute", which is the next link down in the sidenav.
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 11

10 years ago
checked in my patch as r17993 on trunk, r17994 on prod.  
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

10 years ago
I don't know how to verify this until the change to use the mozad.css stylesheet in comment 1 is reverted.
(Assignee)

Comment 13

10 years ago
Huh, I must not understand comment 1, because I'm not seeing mozad.css anywhere on the page on trunk
Okay, I've switched it back on prod.
(Reporter)

Comment 15

10 years ago
(In reply to comment #14)
> Okay, I've switched it back on prod.

Chris, could you do this on stage, too, so that I can verify it?  Thanks!

http://support-stage.mozilla.org/en-US/kb/Other+Firefox+support
Looks like it's already applied to staging.
(Reporter)

Comment 17

10 years ago
Verified FIXED; don't know what I was thinking/seeing.  Thanks, Chris.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Whiteboard: sumo_only theme
You need to log in before you can comment on or make changes to this bug.