Thunderbird should be compatible with Time Machine (Apple Backup)

RESOLVED DUPLICATE of bug 58308

Status

enhancement
RESOLVED DUPLICATE of bug 58308
11 years ago
11 years ago

People

(Reporter: phillip.hahn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: All

Thunderbird has one large db file for my IMAP account, that does not go with the backup system built into Mac OS X.

If on email changes, a huge file (several 100 MB) is marked as "changed" and therefore backed up automatically. This costs a lot of bandwith, time and space every hour.

I would suggest to develop a second db system and let the user choose which one to take, which stores the mails in individual files in a tree-like system resembling the IMAP-folder structure. Thereby, one new mail would only add a few kB to a backup. Furthermore, this system is way more crash proof as a single database file.

To keep it simple for end users, migration between the different db-options should be possible.

Maybe, this featrue would even help upon spotlight integration of Thunderbird Mails...

Thanks a lot,
Phillip

Reproducible: Always

Steps to Reproduce:
1.make time machine backup
2.get new mail
3.time machine backs up the entire db again
Actual Results:  
hard disk space decreases dramatically

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 58308
You need to log in before you can comment on or make changes to this bug.