Mail notification alert shows the binary code of attachment (base64 encoded) when the msg consists only of an attachment

RESOLVED DUPLICATE of bug 449576

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 449576
10 years ago
8 years ago

People

(Reporter: Siyivan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier:  2.0.0.16 (20080708)

The new mail notification window showed:
New mail: Subject line
0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7....

Turns out the message doesn't have any content, just an attachment, which does begin (base64 encoded) with 0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7


Reproducible: Didn't try

Steps to Reproduce:
From: Foo@example.net
Subject: Subject line
To: Bar@example.net
Content-type: multipart/mixed; boundary="Boundary_FOOBAR"

This is a multi-part message in MIME format.

--Boundary_FOOBAR
Content-type: application/msword; NAME="Foo.doc"
Content-transfer-encoding: base64
Content-disposition: attachment;
 filename="Foo.doc"

0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7/C...
Actual Results:  
New mail: Subject line
0M8R4KGxGuEAAAAAAAAAAAAAAAAAAAAAPgADAP7....

Expected Results:  
New mail: Subject line
(No text)

or

New mail: Subject line
Foo.doc

Comment 1

10 years ago
Pretty sure it happens, but there's a bug for it somewhere.
Summary: Mail notification alert shows the binary code of attachment → Mail notification alert shows the binary code of attachment (base64 encoded) when the msg consists only of an attachment
Whiteboard: DUPEME

Comment 2

9 years ago
Can confirm this

Updated

9 years ago
Duplicate of this bug: 418309

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449576
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.