bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

If a flash animation trigguered by a javascript event is not in the viewport, animation is not played and javascript mising element element trigguered

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: Hassan El Forkani, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

if you go to
http://www.mosaiquefm.net/index/a/ActuDetail/Element/4642-Mrad-Mahjoub-part-en-Egypte.html
y'll see that the page load event fires a flash animation on top of the article
instead if you go to 
http://www.mosaiquefm.net/index/a/ActuDetail/Element/4642-Mrad-Mahjoub-part-en-Egypte.html#com (same page, internal anchor)
the animation does not fire and javascript reports a missing element error (document.getElementById(overFlashID).playStart is not a function) has to do with flash animation not being in the view port


Reproducible: Always

Steps to Reproduce:
1. go to http://www.mosaiquefm.net/index/a/ActuDetail/Element/4642-Mrad-Mahjoub-part-en-Egypte.html (correct behavior)
2. go to http://www.mosaiquefm.net/index/a/ActuDetail/Element/4642-Mrad-Mahjoub-part-en-Egypte.html#com (same page, internal anchor, buggy behavior)
3.
Actual Results:  
flash animation not played and javascript error reported

Expected Results:  
flash animation played on page load
(Reporter)

Updated

10 years ago
Summary: If a flas animation trigguered by a javascript event is not in the viewport, animation is not played and javascript mising element element trigguered → If a flash animation trigguered by a javascript event is not in the viewport, animation is not played and javascript mising element element trigguered
Confirmed on Windows Vista.

Works: 2008022702
Fails: 2008022703

Regression window:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2008-02-27+01%3A00&maxdate=2008-02-27+04%3A00
Probably caused by Bug 317189.
Blocks: 317189
Component: OS Integration → Layout
Keywords: regression
Product: Firefox → Core
QA Contact: os.integration → layout
Version: unspecified → Trunk
Hassan, could you perhaps make a minimal testcase that still shows the bug?

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID 	20160519030232

I could not reproduce the issue on latest Nightly using the provided url so I will close this as WFM. 

If anyone can still reproduce the issue fell free to reopen the bug and provide a minimal testcase as requested in comment 2.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.